Skip site navigation (1) Skip section navigation (2)

Re: _USE_32BIT_TIME_T Patch

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Andrew Dunstan <andrew(at)dunslane(dot)net>
Cc: Owais Khan <owais(dot)khan(at)enterprisedb(dot)com>, pgsql-hackers(at)postgresql(dot)org, Hamid Quddus <hamid(dot)quddus(at)enterprisedb(dot)com>
Subject: Re: _USE_32BIT_TIME_T Patch
Date: 2012-08-31 16:41:44
Message-ID: CA+OCxozAP+H+_ZGF2jgDV4kMz3Fti+64mhF2es949D2MLr8zFA@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Fri, Aug 31, 2012 at 5:37 PM, Andrew Dunstan <andrew(at)dunslane(dot)net> wrote:
>
> On 08/31/2012 12:18 PM, Dave Page wrote:
>>
>> On Fri, Aug 31, 2012 at 4:57 PM, Andrew Dunstan <andrew(at)dunslane(dot)net>
>> wrote:
>>>
>>> On 08/31/2012 11:14 AM, Dave Page wrote:
>>>>
>>>> On Fri, Aug 31, 2012 at 4:10 PM, Andrew Dunstan <andrew(at)dunslane(dot)net>
>>>> wrote:
>>>>>
>>>>> On 08/31/2012 11:05 AM, Dave Page wrote:
>>>>>>
>>>>>> I've added this to the release blockers section for 9.2 on the wiki,
>>>>>> as without it, pl/perl is unusable on Win32.
>>>>>
>>>>>
>>>>>
>>>>> I'll have a look at it today.
>>>>
>>>> Thanks Andrew - minor clarification; unusable on MSVC/Win32. I suspect
>>>> Mingw builds may be fine, as they use a much older runtime. Of course,
>>>> we've used MSVC++ for the installer builds for years now.
>>>
>>>
>>>
>>> What exactly is the known combination of things that don't work, and
>>> things
>>> that do work? My only 32 bit test environment for this (ASPerl 5.12.2
>>> build
>>> 1202 [293621], built Sep 6, 2010, Visual C++ Express 2008, Windows XP
>>> SP3)
>>> doesn't seem to have any problem building and running plperl. That makes
>>> it
>>> tough to test if I don't know what exactly needs to change to break
>>> things.
>>
>> We're using VC++ 2010 Pro with ASPerl 5.14.2.1402 for 9.2, and VC++
>> 2008 Pro with ASPerl 5.14.1.1401 at present. Our CM team have tried
>> multiple versions of Perl though, and seen the issue with 5.10 and
>> 5.12 as well though. 5.8 seemed to be OK.
>
>
> OK so from that I'm guessing the issue is probably VC++ 2010, which I don't
> have at all, let alone on a 32-bit machine :-(
>
> Oh, well, I'll look and see if I feel comfortable about the patch anyway.

It's only 2010 for 9.2. We're using 2008 with 9.1, which also exhibits
the problem (see the bug report linked in my first post on this
thread).


-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company


In response to

Responses

pgsql-hackers by date

Next:From: Andrew DunstanDate: 2012-08-31 16:51:42
Subject: Re: _USE_32BIT_TIME_T Patch
Previous:From: Andrew DunstanDate: 2012-08-31 16:37:48
Subject: Re: _USE_32BIT_TIME_T Patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group