Skip site navigation (1) Skip section navigation (2)

Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Giuseppe Sacco <giuseppe(at)eppesuigoccas(dot)homedns(dot)org>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati
Date: 2011-08-24 10:00:51
Message-ID: CA+OCxoyssSg5cTa36JU92A8C=_aGpAR268B4TyFu2gq+siJKPg@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
On Wed, Aug 24, 2011 at 10:40 AM, Giuseppe Sacco
<giuseppe(at)eppesuigoccas(dot)homedns(dot)org> wrote:
> Il giorno mer, 24/08/2011 alle 10.04 +0100, Dave Page ha scritto:
>> On Wed, Aug 24, 2011 at 9:54 AM, Giuseppe Sacco
> [...]
>> > Config log show something about ssl: it seems libpq is detected but not
>> > usable since configure cannot compile with it. libpq require ssl, and I
>> > have openssl 1.0.0d instead of older version. From error messages it
>> > seems libpq cannot work with this version of openssl. Is this true at
>> > all?
>>
>> Doubtful, unless the Debian package is horribly broken. What's the error?
>
> $ ls -l /usr/lib/libssl*
> -rw-r--r-- 1 root root 431786 13 giu 14.03 /usr/lib/libssl.a
> lrwxrwxrwx 1 root root     15 13 giu 14.03 /usr/lib/libssl.so -> libssl.so.1.0.0
> -rw-r--r-- 1 root root 302608  6 apr 20.01 /usr/lib/libssl.so.0.9.8
> -rw-r--r-- 1 root root 312588 13 giu 14.03 /usr/lib/libssl.so.1.0.0
> $ dpkg -S /usr/lib/libssl.so.1.0.0
> libssl1.0.0: /usr/lib/libssl.so.1.0.0
> $ dpkg -l libssl-dev libssl0.9.8 libssl1.0.0 openssl
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Nome                       Versione                   Descrizione
> +++-==========================-==========================-====================================================================
> ii  libssl-dev                 1.0.0d-3                   SSL development libraries, header files and documentation
> ii  libssl0.9.8                0.9.8o-7                   SSL shared libraries
> ii  libssl1.0.0                1.0.0d-3                   SSL shared libraries
> ii  openssl                    1.0.0d-3                   Secure Socket Layer (SSL) binary and related cryptographic tools
>
> So I do have both libssl installed. The default one is 1.0.0d. include files are from 1.0.0d.
>
> This is the part of ssl check in config.log. Later on, when checking for
> lipq, the list of errors is almost the same. I think (at least a few of)
> these errors could be solved linking with libcrypto.so as well.
>
> configure:5403: checking for SSL_library_init in -lssl
> configure:5428: gcc -o conftest -g -O2   conftest.c -lssl   >&5
> /usr/lib/libssl.so: undefined reference to `BIO_pop(at)OPENSSL_1(dot)0(dot)0'
> /usr/lib/libssl.so: undefined reference to `EVP_CipherInit_ex(at)OPENSSL_1(dot)0(dot)0'

<snip>

What version of SSL is your libpq compiled against? You can use 'ldd'
to find out. On squeeze, PG 8.4 appears to use 0.9.8.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

In response to

Responses

pgadmin-support by date

Next:From: Guillaume LelargeDate: 2011-08-24 10:08:55
Subject: Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati
Previous:From: Giuseppe SaccoDate: 2011-08-24 09:40:02
Subject: Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group