Skip site navigation (1) Skip section navigation (2)

Re: wxWidgets 2.9.2 compatibility

From: Dave Page <dpage(at)pgadmin(dot)org>
To: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Cc: Peter Geoghegan <peter(at)2ndquadrant(dot)com>
Subject: Re: wxWidgets 2.9.2 compatibility
Date: 2011-07-13 07:31:41
Message-ID: CA+OCxoxfqH9fo=oor_MBuon-RsGG1f-7w8d4Cw9aEL6EsWK1Yw@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
And today, let's forward the attachement :-p

(thanks Ashesh)

On Tue, Jul 12, 2011 at 5:45 PM, Dave Page <dpage(at)pgadmin(dot)org> wrote:
> So here's the patch I needed to get pgAdmin to build against wxWidgets
> 2.9.2 on Mac. The only obvious problem I see with it when running is
> that the toolbars are displaying text over the graphical buttons which
> needs further investigation.
>
> I'm not really sure why the compiler is unable to resolve this:
>
> ./slony/dlgRepCluster.cpp:815: error: request for member
> ‘GetClientData’ is ambiguous
> /usr/local/include/wx-2.9/wx/ctrlsub.h:297: error: candidates are:
> void* wxItemContainer::GetClientData(unsigned int) const
> /usr/local/include/wx-2.9/wx/event.h:3234: error:
> void* wxEvtHandler::GetClientData() const
>
> Any ideas Peter? It's easy to give it a hint of course, but quite ugly.
>
> --
> Dave Page
> Blog: http://pgsnake.blogspot.com
> Twitter: @pgsnake
>
> EnterpriseDB UK: http://www.enterprisedb.com
> The Enterprise PostgreSQL Company
>



-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Attachment: wx-2.9.2-compat.diff
Description: application/octet-stream (14.5 KB)

In response to

pgadmin-hackers by date

Next:From: Peter GeogheganDate: 2011-07-13 09:27:54
Subject: Re: wxWidgets 2.9.2 compatibility
Previous:From: pgAdmin TracDate: 2011-07-12 16:46:22
Subject: Re: [pgAdmin III] #328: Column collation change has no effect

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group