Skip site navigation (1) Skip section navigation (2)

Re: libber library not found on RC1

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: alexondi <alexondi(at)rambler(dot)ru>, pgsql-bugs(at)postgresql(dot)org
Subject: Re: libber library not found on RC1
Date: 2011-08-25 14:22:06
Message-ID: (view raw or whole thread)
Lists: pgsql-bugs
On Thu, Aug 25, 2011 at 3:17 PM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
> alexondi <alexondi(at)rambler(dot)ru> writes:
>> I update server to RC1 version and after call pg_ctl to start I get this
>> error
>> opt/PostgreSQL/9.1/bin/pg_ctl: error while loading shared libraries:
>> cannot open shared object file: No such file or directory
>> But I have 2.4 version of this library. And I see in ldd pg_ctl that this
>> library was added in RC or why I can't start server without ldap auth?
> How did you install RC1?  The only obvious explanation for this error is
> that you are trying to use somebody else's executables that were built
> for a different environment than you have (specifically, wanting
> different revision numbers of some shared libraries).  If so, you may
> need to build the software locally to get something that will work for
> you.

It's an installer bug that's being worked on at the moment (we added
LDAP support, and ran into an rpath issue).

Dave Page
Twitter: @pgsnake

EnterpriseDB UK:
The Enterprise PostgreSQL Company

In response to


pgsql-bugs by date

Next:From: Tom LaneDate: 2011-08-25 14:52:03
Subject: Re: BUG #6176: pg_dump dumps pg_catalog tables
Previous:From: Tom LaneDate: 2011-08-25 14:17:08
Subject: Re: libber library not found on RC1

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group