Skip site navigation (1) Skip section navigation (2)

Re: Further news on Clang - spurious warnings

From: "David E(dot) Wheeler" <david(at)kineticode(dot)com>
To: Peter Geoghegan <peter(at)2ndquadrant(dot)com>
Cc: PG Hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Further news on Clang - spurious warnings
Date: 2011-08-03 17:33:03
Message-ID: C74A92BB-FB29-48A9-9A7A-72613FC0FBBC@kineticode.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Aug 3, 2011, at 1:47 AM, Peter Geoghegan wrote:

> So, there are 4 remaining warnings.

I haven't been paying attention to warnings, but FWIW 9.1beta3 has been building with LLVM by default with Xcode 4. Both on Snow Leopard and on Lion I saw something like this:

try=# select version();
                                                                                   version                                                                                   
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 PostgreSQL 9.1beta3 on x86_64-apple-darwin11.0.0, compiled by i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00), 64-bit
(1 row)

Which is just awesome. Things seem to work great.

Best,

David

In response to

Responses

pgsql-hackers by date

Next:From: Peter EisentrautDate: 2011-08-03 18:15:37
Subject: Re: Further news on Clang - spurious warnings
Previous:From: Robert HaasDate: 2011-08-03 17:27:21
Subject: Re: WIP fix proposal for bug #6123

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group