Skip site navigation (1) Skip section navigation (2)

Access 2002 linked table behavior

From: "Sufficool, Stanley" <ssufficool(at)rov(dot)sbcounty(dot)gov>
To: <pgsql-odbc(at)postgresql(dot)org>,"PostGIS Users Discussion" <postgis-users(at)postgis(dot)refractions(dot)net>
Subject: Access 2002 linked table behavior
Date: 2008-12-12 19:01:58
Message-ID: C2F174F99918D54CA2A96E57C5079B6F9FADDB@sbc-exmsg2.sbcounty.gov (view raw or flat)
Thread:
Lists: pgsql-odbc
I am debugging a certain application *cough* ArcGIS *cough* using Access
2002 linked tables and PostgreSQL. I am able to get the application to
recognize and work with SQL 2005 linked tables, but it won't with
PostgreSQL linked tables.
 
I have traced all commands going to PG using the pgodbc debug logs and
all the queries are fine. So, now I am left with the ODBC / DAO layers.
I think this has something to do with MSSQL IMAGE versus the PG bytea
type since when it get to handling the bytea blobs, this is where it
seems to crash. I have verified at the DAO layer that all data types and
table/field attributes match between MSSQL and PGSQL linked tables.
 
If I trick the app by allowing initial connect to the SQL linked tables
and then swap the link for the PG table all goes just fine and I can see
the queries passed to PG and drawn on the application screen, but I cant
get the app to do the initial connect to the PG linked table.
 
Is there any extra debug information I can get from the ODBC driver to
see where the failure is?
 
Stanley Sufficool
Systems Analyst
San Bernardino County
909-387-2102
 
P  Please consider the environment before printing this e-mail or its
attachment(s)
 

pgsql-odbc by date

Next:From: Lothar BehrensDate: 2008-12-13 09:49:41
Subject: Re: Numeric datatype doesn't match those from older driver version ?
Previous:From: Hiroshi InoueDate: 2008-12-07 00:55:12
Subject: Re: Numeric datatype doesn't match those from older driver version ?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group