Skip site navigation (1) Skip section navigation (2)

Bug: PgAdmin not displaying typmod column types correctly in create or display

From: "Obe, Regina" <robe(dot)dnd(at)cityofboston(dot)gov>
To: "pgadmin-support(at)postgresql(dot)org" <pgadmin-support(at)postgresql(dot)org>
Subject: Bug: PgAdmin not displaying typmod column types correctly in create or display
Date: 2010-01-04 12:29:54
Message-ID: BD3A1BBF51D14C47B26207A076699482280806323E@XCCMS2.cityhall.boston.cob (view raw or flat)
Thread:
Lists: pgadmin-support
I assume this is a PgAdmin III bug, but I could be wrong.
I'm using PgAdmin 1.10.1 on Windows, but seems to be an issue with even 1.8 since I tried on that too.

The upcoming PostGIS 1.5 has a new type called geography that uses the Typmod functionality introduced in 8.3.

I'm guessing this is a display bug in how PgAdmin is displaying typmod types.

Details here

http://trac.osgeo.org/postgis/ticket/368

What is interesting is if I do a select of the table in question, the geography header shows correctly as

geography(Point,4326) or geography(Linestring,4326)

so it seems its just in the 

CREATE TABLE ... that displays on the side panel of PgAdmin or when you select generate create script.


I could of sworn I saw it right at some point before (but installing a previous experimental build of PostGIS behaved the same). Perhaps I was always focusing on the display of the SELECT... of its display in phppgadmin which correctly displays the type.

In case you need to test, have windows experimental builds here
http://www.postgis.org/download/windows/experimental.php

Thanks,
Regina

-----------------------------------------
The substance of this message, including any attachments, may be
confidential, legally privileged and/or exempt from disclosure
pursuant to Massachusetts law. It is intended
solely for the addressee. If you received this in error, please
contact the sender and delete the material from any computer.

Responses

pgadmin-support by date

Next:From: Sergey StepanovDate: 2010-01-04 18:33:31
Subject: pgagent, problem with running the jobs in FreeBSD
Previous:From: Ashesh VashiDate: 2010-01-04 11:29:09
Subject: Re: pgagent 3.0.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group