Skip site navigation (1) Skip section navigation (2)

Re: 8.0 installs ok, but then...

From: "Jon Allen" <Jon(dot)Allen(at)sas(dot)com>
To: "Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: <pgsql-novice(at)postgresql(dot)org>
Subject: Re: 8.0 installs ok, but then...
Date: 2005-03-23 21:48:23
Message-ID: BBB646166E3FCE46A5E9CE14B252558602D5ECD5@MERC27.na.sas.com (view raw or flat)
Thread:
Lists: pgsql-novice
Thanks for the response.
First, more background:
 - running on win xp
 - my pc is the only one with this problem in a group of about 20 upgrades
 - made sure there's nothing in my PATH that would cause this problem
 - found a workaround: changed "md5" to "trust" in pg_hba.conf

	> ...every psql command I issue gets this response:
	> psql: FATAL:  password authentication failed for user "postgres" even 
	> though there is no password prompt.

	What shows up in the postmaster log?

I can't find a postmaster log. Didn't know what one was til your question prompted me to find out, and I'm having trouble mapping the doc's unix examples to my win environment. As far as I can figure, the postmaster task on my pc is the PostgreSQL Database Server 8.0 service. And I haven't figured out yet where the log is for that.
Here's the content of C:\Program Files\PostgreSQL\8.0\data\pg_log\postgresql-2005-03-23_000000.log:

2005-03-23 11:03:29 FATAL:  password authentication failed for user "jon.allen"
2005-03-23 11:05:08 FATAL:  password authentication failed for user "postgres"
2005-03-23 11:24:05 FATAL:  password authentication failed for user "postgres"
2005-03-23 13:36:41 FATAL:  password authentication failed for user "jon.allen"
2005-03-23 13:36:48 FATAL:  password authentication failed for user "jon.allen"
2005-03-23 13:36:52 FATAL:  password authentication failed for user "jon.allen"
2005-03-23 13:36:54 FATAL:  password authentication failed for user "jon.allen"
2005-03-23 15:07:02 LOG:  received fast shutdown request
2005-03-23 15:07:02 LOG:  shutting down
2005-03-23 15:07:02 LOG:  database system is shut down
2005-03-23 15:07:03 LOG:  logger shutting down

	> I don't have any .pgpass files on my system.

	How about PGPASSWORD environment variable?

No postgres-related environment variables.

	> The install log mentions errors 1707 and 1709, but I can't find any 
	> reference to them.

	Actually showing them to us might help...

The last 12 lines from the install log (let me know if you need to see the whole 3 Mb):

=== Logging stopped: 3/22/2005  15:47:39 ===
MSI (c) (14:60): Note: 1: 1707 
MSI (c) (14:60): Note: 1: 2205 2:  3: Error 
MSI (c) (14:60): Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1707 
MSI (c) (14:60): Note: 1: 2205 2:  3: Error 
MSI (c) (14:60): Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (c) (14:60): Product: PostgreSQL 8.0 -- Installation completed successfully.

MSI (c) (14:60): Grabbed execution mutex.
MSI (c) (14:60): Cleaning up uninstalled install packages, if any exist
MSI (c) (14:60): MainEngineThread is returning 0
=== Verbose logging stopped: 3/22/2005  15:47:40 ===


Responses

pgsql-novice by date

Next:From: Tom LaneDate: 2005-03-23 22:17:56
Subject: Re: 8.0 installs ok, but then...
Previous:From: Ryan SommersDate: 2005-03-23 21:07:29
Subject: Time Conversion

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group