Skip site navigation (1) Skip section navigation (2)

Re: Extensions Dependency Checking

From: Robert Haas <robertmhaas(at)gmail(dot)com>
To: "David E(dot) Wheeler" <david(at)kineticode(dot)com>
Cc: "pgsql-hackers(at)postgresql(dot)org Hackers" <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Extensions Dependency Checking
Date: 2011-04-04 21:31:19
Message-ID: (view raw or whole thread)
Lists: pgsql-hackers
On Fri, Apr 1, 2011 at 11:45 AM, David E. Wheeler <david(at)kineticode(dot)com> wrote:
> But I'm assuming that at some point there's going to be something a bit more robust: specifically, requiring a minimum version, perhaps something like:
>    requires = 'foo 1.0, bar 0.31.4'

Or maybe:

requires = 'foo = 1.0, bar >= 0.31.4'

> * I think we're going to need a formal version string spec for extensions.

I agree.

> * If that's true, I think it should be specified *now*, before extensions are in the wild, so that we don't end up with the legacy version string nightmares that Perl modules suffer from.

I think I agree with this, too.

> * If we do adopt a spec, I think it should reflect the PostgreSQL core version strings as closely as possible, and should be fully compatible with them.

I am less sure about this one.

> * So it might be worth looking at semver or something similar to integrate.

No.  It's too late to be monkeying with this.  I think for 9.1 we will
need to content ourselves with setting a good precedent, rather than
enforcing it programatically.  It's not going to work to insist on all
numeric version strings anyway, because we've already got this 'FROM
unpackaged' bit floating around.

Robert Haas
The Enterprise PostgreSQL Company

In response to


pgsql-hackers by date

Next:From: Tom LaneDate: 2011-04-04 21:48:34
Subject: Re: Extensions Dependency Checking
Previous:From: Robert HaasDate: 2011-04-04 21:22:33
Subject: Re: GUC assign hooks (was Re: wal_buffers = -1 and SIGHUP)

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group