Skip site navigation (1) Skip section navigation (2)

Re: PostGIS 1.5.2 Doesn't compile with PG 9.1Beta1

From: Póka Balázs <poka(at)idata(dot)hu>
To: pgsql-testers(at)postgresql(dot)org
Subject: Re: PostGIS 1.5.2 Doesn't compile with PG 9.1Beta1
Date: 2011-05-12 23:20:11
Message-ID: BANLkTimLkK7G_3E-Ln=12eg0qPcBHCpUoA@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-testers
Hi,

2011/5/13 Noel Proffitt <noelp(at)calpacs(dot)org>:
> As of PG9.1Beta1, PostGIS 1.5.2, the current stable version, will not compile due to an added argument to
> InitFunctionCallInfoData.

I bumped into this problem earlier. I made a simple modification to
the only line which contains this call (lwgeom_accum.c:306), and
changed it to:

InitFunctionCallInfoData(fcinfo, NULL, 1, InvalidOid, NULL, NULL);

It compiles, and seems to work. Nevertheless, expert advice is welcome.

regards,
Balázs Póka

In response to

pgsql-testers by date

Next:From: Emanuel CalvoDate: 2011-05-24 11:49:55
Subject: [PG 9.1 beta] Could not open relation
Previous:From: Noel ProffittDate: 2011-05-12 22:09:39
Subject: PostGIS 1.5.2 Doesn't compile with PG 9.1Beta1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group