2011/5/24 Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>:
> Hitoshi Harada <umi(dot)tanuki(at)gmail(dot)com> writes:
>> It looks to me like mergejoin_allowed should be initialized to false.
>> If enable_mergejoin is off and jointype != JOIN_FULL then mergejoin is
>> not allowed, isn't it? Sorry for noise if it's only my confusing.
> No, the code is correct as-is: we need the flag to be set true by
> default, because the way that the function is using it, we'll also skip
> some nestloop possibilities when it's false. Note the comment for step
> It could be that a different name for that flag variable would be a
> better idea, but neither Robert nor I could come up with a better one.
Ah, ok. I think I now understand it. "mergejoin_doable" flag. Thanks.
In response to
pgsql-committers by date
|Next:||From: Bruce Momjian||Date: 2011-05-25 04:00:17|
|Subject: pgsql: Add C comment about why we don't spell out "month" in intervalv|
|Previous:||From: Tom Lane||Date: 2011-05-24 22:52:22|
|Subject: pgsql: Grammar cleanup for src/test/isolation/README|