Skip site navigation (1) Skip section navigation (2)

Fix for Perl 5.14

From: Alex Hunsaker <badalex(at)gmail(dot)com>
To: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Fix for Perl 5.14
Date: 2011-04-23 07:02:13
Message-ID: BANLkTi=qRfqpPfQTO2R5amb_cFsYHdVWwQ@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-hackers
Perl 5.14.0-RC1 came out a few days ago...

There is a minor compile time error due to the API changing a bit:
plperl.c:929:3: error: lvalue required as left operand of assignment

This is due to GvCV() no longer returning an lvalue, instead they want
us to use the new GvCV_set macro. (see
http://search.cpan.org/~jesse/perl-5.14.0-RC1/pod/perldelta.pod#GvCV()_and_GvGP()_are_no_longer_lvalues)

Unfortunately  that macro is not available on older perls so the
attached provides our own macro when GvCV_set is not defined.

Tested with 5.14.0-rc1 and 5.12.3.

The -head patch applies with fuzz to 9.0. The 8.4 patch applies clean
to 8.4 and with fuzz to 8.3 and 8.2.

Attachment: plperl_5.14_8.4.patch
Description: text/x-patch (930 bytes)
Attachment: plperl_5.14_head.patch
Description: text/x-patch (930 bytes)

Responses

pgsql-hackers by date

Next:From: Andrew DunstanDate: 2011-04-23 13:00:12
Subject: Re: Fix for Perl 5.14
Previous:From: David ChristensenDate: 2011-04-23 04:46:54
Subject: Re: "stored procedures"

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group