Skip site navigation (1) Skip section navigation (2)

Re: Branch 1.14?

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Jasmin Dizdarevic <jasmin(dot)dizdarevic(at)gmail(dot)com>
Cc: Guillaume Lelarge <guillaume(at)lelarge(dot)info>, "pgadmin-hackers(at)postgresql(dot)org" <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: Branch 1.14?
Date: 2011-06-14 22:41:19
Message-ID: BANLkTi=LJ76czL4C+F=6rgCfX=eM2-W2yg@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
We don't tend to remove the old code as that can lead to painful
amounts of refactoring to make things look right afterwards. If you
feel so inclined though, go ahead and do some cleanup.

On Tuesday, June 14, 2011, Jasmin Dizdarevic
<jasmin(dot)dizdarevic(at)gmail(dot)com> wrote:
> I absolutely agree. In this case, I think, we should remove old compatibility checks in the code from time to time. I was shocked when I saw BackendMinimumVersion(7,3) - I thought that I have to check the search-feature against 7.3 *g*
>
> 2011/6/15 Dave Page <dpage(at)pgadmin(dot)org>
>
> The one about the versions :-p
>
> Seriously though, no, we don't support 7.3 - iirc we agreed to drop
> that a few years back. I'm fine with un-supporting 8.0 and 8.1 too.
>
> On Tuesday, June 14, 2011, Jasmin Dizdarevic
> <jasmin(dot)dizdarevic(at)gmail(dot)com> wrote:
>> Let's play jeopardy:
>> Is 7.3 really the current minimum version for pgAdmin 1.14 or 1.15?
>>
>> OR
>>
>> Shouldn't the minimum version of pgAdmin reflect the minimum version supported/patched by PostgreSQL (currently 8.2.21)?
>>
>> Which question matches your answer?
>>
>> 2011/6/14 Dave Page <dpage(at)pgadmin(dot)org>
>> Yes, I think so.
>>
>> On Tuesday, June 14, 2011, Jasmin Dizdarevic
>> <jasmin(dot)dizdarevic(at)gmail(dot)com> wrote:
>>> =)
>>> BTW:
>>> [...]The application may be used on Linux, FreeBSD, Solaris, Mac OSX and Windows platforms to manage PostgreSQL 7.3 and above running on any platform[...]
>>>
>>> Is 7.3 really the current minimum version for pgAdmin 1.14 or 1.15?
>>> Shouldn't the minimum version of pgAdmin reflect the minimum version supported/patched by PostgreSQL (currently 8.2.21)?
>>>
>>> 2011/6/14 Guillaume Lelarge <guillaume(at)lelarge(dot)info>
>>>
>>> On Tue, 2011-06-14 at 22:00 +0100, Dave Page wrote:
>>>> On Tuesday, June 14, 2011, Guillaume Lelarge <guillaume(at)lelarge(dot)info> wrote:
>>>> > On Tue, 2011-06-14 at 20:57 +0200, Jasmin Dizdarevic wrote:
>>>> >> Excuse me? *g*
>>>> >>
>>>> >
>>>> > Yeah, I don't think I'll have the time to work on new features now. Too
>>>> > much other things to do.
>>>>
>>>> I think Jasmine is alluding to the object search patch that's in progress :-)
>>>>
>>>
>>> Oops, sorry, forgot that patch.
>>>
>>>
>>> --
>>> Guillaume
>>>   http://blog.guillaume.lelarge.info
>>>   http://www.dalibo.com
>>>
>>>
>>>
>>>
>>
>> --
>> Dave Page
>> Blog: http://pgsnake.blogspot.com
>> Twitter: @pgsnake
>>
>> EnterpriseDB UK: http://www.enterprisedb.com
>> The Enterprise PostgreSQL Company
>>
>>
>>
>
> --
> Dave Page
> Blog: http://pgsnake.blogspot.com
> Twitter: @pgsnake
>
> EnterpriseDB UK: http://www.enterprisedb.com
> The Enterprise PostgreSQL Company
>
>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

In response to

Responses

pgadmin-hackers by date

Next:From: Jasmin DizdarevicDate: 2011-06-14 23:03:58
Subject: Re: Discussion - Search Objects
Previous:From: Jasmin DizdarevicDate: 2011-06-14 22:22:32
Subject: Re: Branch 1.14?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group