Skip site navigation (1) Skip section navigation (2)

Difficulty installing postgresql on Max OSX Leopard.

From: Don Fox <donfox1(at)mac(dot)com>
To: pgsql-novice(at)postgresql(dot)org
Subject: Difficulty installing postgresql on Max OSX Leopard.
Date: 2009-10-30 13:02:50
Message-ID: B98793D2-A213-4C24-A566-5F69B034D12B@mac.com (view raw or flat)
Thread:
Lists: pgsql-novice
I'm working with an open source Electronic Medical Record  application  
'GNUmed" which uses postgresql. I've had a difficult time installing  
version 8.4.1 from source code on my Mac.

The best set of instruction i've found is from http://zanshin.net/2009/09/07/installing-postgresql-on-mac-10-6-snow-leopard/ 
,  however it did not quite do the trick. Going by the instructions  
there:

> On starting the server:
>
>  bash-3.2$ /usr/local/pgsql/bin/pg_ctl -D /usr/local/pgsql/data/ -l  
> server.log start
> zanshin.net » Installing PostgreSQL on Mac 10.6 (Snow Leopard) »  
> Blog Archive    server starting
>
> If I use this command to stop server I get:
>
> /usr/local/pgsql/bin/pg_ctl -D /usr/local/pgsqsl/data/ -l server.log  
> stop
> pg_ctl: PID file "/usr/local/pgsqsl/data/postmaster.pid" does not  
> exist
> Is server running?

> Creating the db:
>     bash-3.2$ createdb testdb
>     createdb: could not connect to database postgres: could not  
> connect to server: No such file or directory
> 	Is the server running locally and accepting
> 	connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

>  The server.log entries:
>        postgres cannot access the server configuration file "/usr/ 
> local/pgsql/data/postgresql.conf": No such file or directory
>
> The file does exist
>        ls data
>       PG_VERSION	global		pg_hba.conf	pg_multixact	pg_subtrans	 
> pg_twophase	postgresql.conf
>       base		pg_clog		pg_ident.conf	pg_stat_tmp	pg_tblspc	pg_xlog		 
> postmaster.opts

Also, when attempting to unzip some src files, including the one I got  
from this site I get this:

tar -zxvf  postgresql-8.4.1.tar.gz
tar: Unrecognized archive format: Inappropriate file type or format
tar: Error exit delayed from previous errors.

THis is very  strange to me!

The file I'm using came from source forge.

Any hints about this installation is greatly appreciated.

Don Fox

P.S. The app that will using postgresql is written in python.

Responses

pgsql-novice by date

Next:From: Mladen GogalaDate: 2009-10-30 15:19:17
Subject: Re: Difficulty installing postgresql on Max OSX Leopard.
Previous:From: Don FoxDate: 2009-10-30 03:49:14
Subject: Difficulty installing postgresql on Max OSX Leopard.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group