Skip site navigation (1) Skip section navigation (2)

Issues with imported blobs from Postgres 8 to 9

From: Mahdi Mankai <mahdi(dot)mankai(at)fuegoondemand(dot)com>
To: pgsql-general(at)postgresql(dot)org
Subject: Issues with imported blobs from Postgres 8 to 9
Date: 2011-02-28 06:44:48
Message-ID: AFDEB286-DF00-4F1D-AA23-D877AB53A1C4@fuegoondemand.com (view raw or flat)
Thread:
Lists: pgsql-general
Hi,

I created a database dumb using pg_dump on Postgres 8.3.6. After that I tried to import the same database into a Postgres 9.0 install. Everything worked fine except some image blobs. Some of them seem to be corrupt.

OS: Mac OS X Server 10.5.8. The same issue happened on Mac OS X client 10.6.6.

I downloaded the Postgres 9 version taken from Enterprise DB. I also tried the one from http://www.postgresqlformac.com/ since my initial database was created in Postgres 8 downloaded from there. I had the same issue.

In some forums, it was mentioned that I needed to set bytea_output = 'escape' in the config file. Which I did with no luck even after deleting and importing the DB again.

Any suggestion?

Thanks,

Mahdi

Responses

pgsql-general by date

Next:From: Álvaro PlataDate: 2011-02-28 12:22:14
Subject: NullPointerException when making a getCapabilities request
Previous:From: Michael HarrisDate: 2011-02-28 06:27:08
Subject: Re: ERROR: missing chunk number 0 for toast value 382548694 in pg_toast_847386

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group