Skip site navigation (1) Skip section navigation (2)

Re: Anyone got an Intel Mac yet?

From: Guy Turcotte <turgu(at)sympatico(dot)ca>
To: Dave Page <dpage(at)vale-housing(dot)co(dot)uk>, pgadmin-hackers(at)postgresql(dot)org, pgadmin-support(at)postgresql(dot)org
Subject: Re: Anyone got an Intel Mac yet?
Date: 2006-03-30 16:37:44
Message-ID: AB72696E-1D98-4822-96C8-10FCD21C281A@sympatico.ca (view raw or flat)
Thread:
Lists: pgadmin-hackerspgadmin-support
Hi Dave,

I'm running Tiger V10.4.5 on an iMac 2Ghz Intel Core Duo.

I'm trying to compile pgadmin but I'm getting problems  
with .configure . As I'm a newbie on this platform...

Here is the result I get:

[start]

...$  ./configure --enable-appbundle --with-pgsql=/Library/PostgreSQL  
--with-wx=/usr/bin

....

checking libpq-fe.h usability... yes
checking libpq-fe.h presence... yes
checking for libpq-fe.h... yes
checking pgsql in /Library/PostgreSQL... ok
checking for wxWidgets... yes
ls: wx*-2.4-config: No such file or directory
ls: wx*-2.4-config: No such file or directory

   Warning: No config found to match: /usr/bin/wx-config --cppflags -- 
unicode=yes --debug=no --version=2.6
            in /usr/lib/wx/config
   If you require this configuration, please install the desired
   library build.  If this is part of an automated configuration
   test and no other errors occur, you may safely ignore it.
   You may use wx-config --list to see all configs available in
   the default prefix.

ls: wx*-2.4-config: No such file or directory
ls: wx*-2.4-config: No such file or directory

   Warning: No config found to match: /usr/bin/wx-config --static=no  
--libs --unicode=yes --debug=no --version=2.6
            in /usr/lib/wx/config
   If you require this configuration, please install the desired
   library build.  If this is part of an automated configuration
   test and no other errors occur, you may safely ignore it.
   You may use wx-config --list to see all configs available in
   the default prefix.

ls: wx*-2.4-config: No such file or directory
ls: wx*-2.4-config: No such file or directory

   Warning: No config found to match: /usr/bin/wx-config --static=no  
--libs stc,ogl --unicode=yes --debug=no --version=2.6
            in /usr/lib/wx/config
   If you require this configuration, please install the desired
   library build.  If this is part of an automated configuration
   test and no other errors occur, you may safely ignore it.
   You may use wx-config --list to see all configs available in
   the default prefix.

configure: error: Your wxWidgets installation cannot support pgAdmin  
in the selected configuration. This may be because it was configured  
without the --enable-unicode option, or the combination of dynamic/ 
static linking and debug/non-debug libraries selected did not match  
any installed wxWidgets libraries.

[end]

I tried to identify my version of wxWidget (2.5.3) without success...

I can try things on my computer on you behalf if you like...

-- Guy

On 20-Mar-06, at 10:30 AM, Dave Page wrote:

> Does anyone have an Intel Mac that they would be willing do try  
> building
> pgAdmin on? There's certainly one script that will fail, but I'm kinda
> hoping that will be all :-). It would be good to know for sure, and be
> able to fix the script (lines 20/26 of
> http://svn.pgadmin.org/cgi-bin/viewcvs.cgi/trunk/pgadmin3/pkg/mac/ 
> comple
> te-bundle.sh?rev=5055&view=markup presumably need 'ppc' changed to
> 'i386' or 'intel' or something).
>
> Cheers, Dave.
>
>


In response to

pgadmin-hackers by date

Next:From: Nasir AhmedDate: 2006-03-30 18:41:33
Subject: Unsubscribe me
Previous:From: svnDate: 2006-03-30 16:32:20
Subject: SVN Commit by dpage: r5067 - trunk/pgadmin3/src

pgadmin-support by date

Next:From: Dave PageDate: 2006-03-30 19:18:33
Subject: Re: Anyone got an Intel Mac yet?
Previous:From: Dave PageDate: 2006-03-29 19:16:32
Subject: Re: pgadmin 1.4 not remembering password

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group