Skip site navigation (1) Skip section navigation (2)

Re: actualizar a la nueva version

From: Horacio Miranda <hmiranda(at)gmail(dot)com>
To: Diego Ayala <netdiego81(at)gmail(dot)com>
Cc: Jaime Casanova <jaime(at)2ndquadrant(dot)com>, Postgres Ayuda <pgsql-es-ayuda(at)postgresql(dot)org>
Subject: Re: actualizar a la nueva version
Date: 2010-05-18 21:35:46
Message-ID: AANLkTinoT-JOtisPKOY3Mo16ej0pdCWEotQCX20GyHQX@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Debes elegir un camino de RPM o binarios, la gracia de usar RPM es que
se gestionan los paquetes con un repositorio. Si quieres los binarios
en la documentación puedes hacer algo como rpmbuild --rebuild
archivo.tar.gz (me parece que ese es el formato). De hecho sería bueno
que hicieras esto con una maquina distinta (para no infectar de
instaladores en la maquina de producción) de hecho lo ideal es no
tener ni siquiera el gcc en las maquinas productivas (si te entran por
apache, y te suben un programa en C, algo como un exploit) se puede
compilar. Bueno en realidad si te suben un binario es como lo mismo,
pero depende del grado de seguridad que quieras poner en tu maquina.
(eso es otra historia).

2010/5/19 Diego Ayala <netdiego81(at)gmail(dot)com>:
> muchas gracias Jaime, esa era justamente la duda q tenia con relacion a los
> rpm, lo probare a ver q tal me va, obviamente, sobre una plataforma de
> desarrollo ;-)
>
> El 18 de mayo de 2010 12:46, Jaime Casanova <jaime(at)2ndquadrant(dot)com>
> escribió:
>>
>> 2010/5/18 Diego Ayala <netdiego81(at)gmail(dot)com>:
>> > Buen dia amigos, tengo una consulta tonta, pero quiero tener la
>> > seguridad de
>> > como debo actualizar mi version 8.4.1 al 8.4.4, siendo que la
>> > instalación la
>> > hice desde los rpm y no con el source..!!, viendo en la lista
>> > recomiendan
>> > solo bajar el sistema y  actualizar los binarios, pero no me queda claro
>> > eso..!!! como hacerlo con los rpm.
>> >
>>
>> no se como trabajan los rpm, pero en realidad bastaria con que bajaras
>> los fuentes, compilaras y ya... pero debes asegurarte de configurar
>> los fuentes (usando el comando ./configure) con exactamente los mismos
>> parametros que tiene el rpm (especialmente las carpetas que el rpm
>> escogio para poner las cosas), eso lo puedes hacer ejecutando
>> "pg_config | grep CONFIGURE" y usas los mismos parametros que ahi te
>> indica
>> quiza los rpm son lo suficientemente listos para hacer exactamente eso
>> si le dices upgrade y no install
>>
>> viendo los release notes, parece que ademas despues de actualizar
>> debes hacer REINDEX de cualquier indice hash que puedas tener.
>>
>> --
>> Jaime Casanova         www.2ndQuadrant.com
>> Soporte y capacitación de PostgreSQL
>
>
>
> --
> Diego Ayala
>



-- 
Saludos,
Horacio Miranda Aguilera.
RedHat Certified Engineer
DBA Oracle - Large databases
+56 2  8974500

In response to

pgsql-es-ayuda by date

Next:From: Horacio MirandaDate: 2010-05-18 21:38:01
Subject: Re: [pgsql-es-ayuda] Re: [pgsql-es-ayuda] Error al r?==?ISO-8859-1?Q?ealizar una sentencia SELECT LIMIT 1 usando una conexión OD?==?ISO-8859-1?Q?BC
Previous:From: Horacio MirandaDate: 2010-05-18 21:18:36
Subject: Re: TABLESPACE pg_default sin espacio en disco

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group