On Thu, Apr 29, 2010 at 1:18 PM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
> I've just realized that one of the confusing things about this debate
> is that the recovery_connections parameter is very confusingly named.
> It might have been okay when HS existed in isolation, but with SR in the
> mix, it's not at all clear that the parameter refers to client
> connections made to a standby server, and not to replication connections
> made from a standby to its master. It is easy to think that this is a
> parameter that needs to be turned on in the master to allow standby
> slaves to connect to it.
> Another problem is that it looks more like an integer parameter
> (ie, maximum number of such connections) than a boolean.
> I think a different name would help. The best idea I can come up with
> on the spur of the moment is "allow_standby_queries", but I'm not sure
> that can't be improved on. Comments?
I agree that name is better. It would also be nice if the name of
that GUC matched the value that must be set for wal_level as closely
In response to
pgsql-hackers by date
|Next:||From: Kevin Grittner||Date: 2010-04-29 17:28:55|
|Subject: Re: s/recovery_connections/allow_standby_queries/, or something like that?|
|Previous:||From: Robert Haas||Date: 2010-04-29 17:20:03|
|Subject: Re: Re: [COMMITTERS] pgsql: Make CheckRequiredParameterValues() depend upon correct|