On Thu, Dec 30, 2010 at 9:55 PM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
> I wrote:
>> Robert Haas <robertmhaas(at)gmail(dot)com> writes:
>>> This is cool, but on first blush your changes to
>>> add_paths_to_joinrel() appear to be total nonsense. I think the
>>> problem is that have_nonmergeable_clause is really a misnomer - it's
>>> not clear until you read through the whole diff that this won't get
>>> set for inner/left joins.
>> Yeah, I wasn't totally satisfied with that variable name either.
>> Do you have a better idea?
> On reflection, how about inverting the flag's value and calling it
> mergejoin_allowed or some such?
Yeah, that's better.
The Enterprise PostgreSQL Company
In response to
pgsql-committers by date
|Next:||From: Tom Lane||Date: 2010-12-31 17:00:07|
|Subject: pgsql: Invert and rename flag variable to improve code readability.|
|Previous:||From: Tom Lane||Date: 2010-12-31 03:13:09|
|Subject: pgsql: Move symbols for ExecMergeJoin's state machine intonodeMergejoi|