Skip site navigation (1) Skip section navigation (2)

Re: libpq related crash

From: Ramanujam <innomotive(at)gmail(dot)com>
To: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: libpq related crash
Date: 2010-08-26 06:25:48
Message-ID: AANLkTime6us4H_HYD_KvM0DBUAOBZg4v9oJM+LR9hNay@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
On Thu, Aug 26, 2010 at 2:48 PM, Guillaume Lelarge
<guillaume(at)lelarge(dot)info> wrote:
> Le 26/08/2010 07:35, Ramanujam a écrit :
> I'm pretty sure you have an old libpq library around, and that pgAdmin
> uses this one. Be careful that libpq is a different package on Ubuntu (I
> mean, not a postgresql-*, but a libpq*). Try "ldd $(which pgadmin3) |
> grep libpq" to find which one library file it uses.
>
> To launch pgAdmin, you can try this on a terminal:
>
> export LD_LIBRARY_PATH=/usr/local/pgsql/lib:$LD_LIBRARY_PATH
> pgadmin3
>
> After the export, if /usr/local/pgsql is the location of your 8.4
> PostgreSQL binaires, then pgAdmin should connect to your databases if
> you launch if from the same terminal.

You were right. There was an old libpq that was getting referred to
ahead of the intended one.

Works great now. Thanks.

In response to

pgadmin-hackers by date

Next:From: Dave PageDate: 2010-08-26 07:41:22
Subject: Fwd: [HACKERS] Packaging of PG 9.0RC1
Previous:From: Guillaume LelargeDate: 2010-08-26 05:48:36
Subject: Re: libpq related crash

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group