Skip site navigation (1) Skip section navigation (2)

Re: pg_upgrade invalid option

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Thom Brown <thombrown(at)gmail(dot)com>
Cc: pgsql-docs <pgsql-docs(at)postgresql(dot)org>
Subject: Re: pg_upgrade invalid option
Date: 2010-06-11 13:55:40
Message-ID: AANLkTileXqaJD8kwfTgSFGVFyfmNiSj4tF0YK49BnlDg@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-docs
On Fri, Jun 11, 2010 at 2:50 PM, Thom Brown <thombrown(at)gmail(dot)com> wrote:
> I've tried following the instructions on this page:
> http://www.postgresql.org/files/documentation/books/aw_pgsql/node267.html
>
> This mentions a -f option but my version of pg_upgrade doesn't appear
> to support this:
>
> /usr/lib64/postgresql-9.0/bin/pg_upgrade: invalid option -- 'f'
>
> The only options available are:
>
<snip>

> Are those instructions for an older version?
>

That's Bruce's book which is probably 8 or 9 years old now. It's
almost certainly referring to the old pg_upgrade shell script from
years ago.

-- 
Dave Page
EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise Postgres Company

In response to

Responses

pgsql-docs by date

Next:From: Thom BrownDate: 2010-06-11 14:01:11
Subject: Re: pg_upgrade invalid option
Previous:From: Thom BrownDate: 2010-06-11 13:50:45
Subject: pg_upgrade invalid option

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group