Skip site navigation (1) Skip section navigation (2)

Re: Bug: Overwrites incorrect file

From: David Jarvis <thangalin(at)gmail(dot)com>
To: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
Cc: Dave Page <dpage(at)pgadmin(dot)org>, pgadmin-support(at)postgresql(dot)org
Subject: Re: Bug: Overwrites incorrect file
Date: 2010-06-26 23:34:24
Message-ID: AANLkTilTVf3cGDWwkKeX9dDckNTAADmhKBMyyHu2qBpK@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
Hi,

I compiled a debug version of pgAdmin3. The problem still happens. I have
not yet made it crash, but it continually uses the previous file (or
directory) in the dialog. The ldd:

        linux-vdso.so.1 =>  (0x00007fff8bbff000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f1e3ca96000)
        libwx_gtk2ud_stc-2.8.so.0 => /usr/lib/libwx_gtk2ud_stc-2.8.so.0
(0x00007f1e3c791000)
        libwx_gtk2ud_ogl-2.8.so.0 => /usr/lib/libwx_gtk2ud_ogl-2.8.so.0
(0x00007f1e3c524000)
        libwx_gtk2ud_richtext-2.8.so.0 =>
/usr/lib/libwx_gtk2ud_richtext-2.8.so.0 (0x00007f1e3c226000)
        libwx_gtk2ud_aui-2.8.so.0 => /usr/lib/libwx_gtk2ud_aui-2.8.so.0
(0x00007f1e3bfa8000)
        libwx_gtk2ud_xrc-2.8.so.0 => /usr/lib/libwx_gtk2ud_xrc-2.8.so.0
(0x00007f1e3bcfd000)
        libwx_gtk2ud_qa-2.8.so.0 => /usr/lib/libwx_gtk2ud_qa-2.8.so.0
(0x00007f1e3bad9000)
        libwx_gtk2ud_html-2.8.so.0 => /usr/lib/libwx_gtk2ud_html-2.8.so.0
(0x00007f1e3b820000)
        libwx_gtk2ud_adv-2.8.so.0 => /usr/lib/libwx_gtk2ud_adv-2.8.so.0
(0x00007f1e3b52d000)
        libwx_gtk2ud_core-2.8.so.0 => /usr/lib/libwx_gtk2ud_core-2.8.so.0
(0x00007f1e3aec6000)
        libwx_baseud_xml-2.8.so.0 => /usr/lib/libwx_baseud_xml-2.8.so.0
(0x00007f1e3acb9000)
        libwx_baseud_net-2.8.so.0 => /usr/lib/libwx_baseud_net-2.8.so.0
(0x00007f1e3aa86000)
        libwx_baseud-2.8.so.0 => /usr/lib/libwx_baseud-2.8.so.0
(0x00007f1e3a6f7000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00007f1e3a3a7000)
        libxslt.so.1 => /usr/lib/libxslt.so.1 (0x00007f1e3a16b000)
        libpq.so.5 => /usr/lib/libpq.so.5 (0x00007f1e39f43000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f1e39c2f000)
        libm.so.6 => /lib/libm.so.6 (0x00007f1e399ab000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f1e39794000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00007f1e39577000)
        libc.so.6 => /lib/libc.so.6 (0x00007f1e391f4000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f1e38fce000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x00007f1e38dca000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0
(0x00007f1e38bc1000)
        libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x00007f1e389be000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x00007f1e387a5000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0
(0x00007f1e38182000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0
(0x00007f1e37ed5000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00007f1e37cb4000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0
(0x00007f1e37a89000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0
(0x00007f1e3786d000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007f1e375ba000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00007f1e3736f000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f1e370e9000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1
(0x00007f1e36eb4000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0
(0x00007f1e36c6b000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0
(0x00007f1e36a67000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0
(0x00007f1e36862000)
        librt.so.1 => /lib/librt.so.1 (0x00007f1e36659000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00007f1e3637b000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00007f1e36178000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x00007f1e35f6e000)
        libpng12.so.0 => /lib/libpng12.so.0 (0x00007f1e35d47000)
        libz.so.1 => /lib/libz.so.1 (0x00007f1e35b30000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x00007f1e3590b000)
        libtiff.so.4 => /usr/lib/libtiff.so.4 (0x00007f1e356a9000)
        libdl.so.2 => /lib/libdl.so.2 (0x00007f1e354a5000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x00007f1e3527a000)
        libssl.so.0.9.8 => /lib/libssl.so.0.9.8 (0x00007f1e3502a000)
        libcrypto.so.0.9.8 => /lib/libcrypto.so.0.9.8 (0x00007f1e34c99000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2
(0x00007f1e34a65000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00007f1e3482c000)
        libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2
(0x00007f1e345df000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f1e3cd81000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f1e343cd000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f1e341c2000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f1e33fb2000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00007f1e33da9000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f1e33b9e000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0
(0x00007f1e33991000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f1e3365b000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1
(0x00007f1e33457000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f1e33254000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f1e3304e000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00007f1e32dca000)
        libpcre.so.3 => /lib/libpcre.so.3 (0x00007f1e32b9c000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x00007f1e3297d000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x00007f1e32762000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x00007f1e3255c000)
        liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0x00007f1e3234e000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x00007f1e32133000)
        libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0x00007f1e31e91000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f1e31c74000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f1e31a1b000)
        libdirectfb-1.2.so.0 => /usr/lib/libdirectfb-1.2.so.0
(0x00007f1e31798000)
        libfusion-1.2.so.0 => /usr/lib/libfusion-1.2.so.0
(0x00007f1e3158d000)
        libdirect-1.2.so.0 => /usr/lib/libdirect-1.2.so.0
(0x00007f1e31374000)
        libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0
(0x00007f1e31170000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0
(0x00007f1e30f66000)
        libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0x00007f1e30d55000)
        libgcrypt.so.11 => /lib/libgcrypt.so.11 (0x00007f1e30adc000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f1e308d8000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f1e306d2000)
        libgpg-error.so.0 => /lib/libgpg-error.so.0 (0x00007f1e304cd000)

I have pgadmin3 loaded up in ddd. If someone wants to tell me where I should
set a break-point, that would be great.

Dave

In response to

pgadmin-support by date

Next:From: David JarvisDate: 2010-06-27 00:21:38
Subject: Re: Bug: Overwrites incorrect file
Previous:From: Guillaume LelargeDate: 2010-06-26 21:41:25
Subject: Re: Bug: Overwrites incorrect file

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group