Skip site navigation (1) Skip section navigation (2)

Re: Problem installing pgadmin3-1.12.1

From: Ashesh Vashi <ashesh(dot)vashi(at)enterprisedb(dot)com>
To: Peter Oram <peter(dot)oram(at)dodo(dot)com(dot)au>
Cc: "pgadmin-support(at)postgresql(dot)org" <pgadmin-support(at)postgresql(dot)org>
Subject: Re: Problem installing pgadmin3-1.12.1
Date: 2010-12-20 06:31:28
Message-ID: AANLkTikTMi4c092ChDnXSwf1i6OHjmE=RKxm3C_iOd0P@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
Hi Peter,

It seems, it's trying to load wxWidgets library from the '/usr/lib'.
You need to export the LD_LIBRARY_PATH as show below, before running the
pgadmin3.
*export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
./pgadmin3*

--
Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise Postgres Company<http://www.enterprisedb.com>



*http://www.linkedin.com/in/asheshvashi*<http://www.linkedin.com/in/asheshvashi>


On Mon, Dec 20, 2010 at 11:57 AM, Peter Oram <peter(dot)oram(at)dodo(dot)com(dot)au> wrote:

>  # ldd /usr/local/pgadmin3/bin/pgadmin3
>     libssl.so.0.9.8 =>     /usr/lib/libssl.so.0.9.8
>     libkrb5.so.1 =>     /usr/lib/libkrb5.so.1
>     libnsl.so.1 =>     /usr/lib/libnsl.so.1
>     libwx_gtk2u_stc-2.8.so.0 =>     /usr/lib/libwx_gtk2u_stc-2.8.so.0
>     libwx_gtk2u_ogl-2.8.so.0 =>     /usr/lib/libwx_gtk2u_ogl-2.8.so.0
>     libwx_gtk2u_richtext-2.8.so.0 =>
>  /usr/lib/libwx_gtk2u_richtext-2.8.so.0
>     libwx_gtk2u_aui-2.8.so.0 =>     /usr/lib/libwx_gtk2u_aui-2.8.so.0
>     libwx_gtk2u_xrc-2.8.so.0 =>     /usr/lib/libwx_gtk2u_xrc-2.8.so.0
>     libwx_gtk2u_qa-2.8.so.0 =>     /usr/lib/libwx_gtk2u_qa-2.8.so.0
>     libwx_gtk2u_html-2.8.so.0 =>     /usr/lib/libwx_gtk2u_html-2.8.so.0
>     libwx_gtk2u_adv-2.8.so.0 =>     /usr/lib/libwx_gtk2u_adv-2.8.so.0
>     libwx_gtk2u_core-2.8.so.0 =>     /usr/lib/libwx_gtk2u_core-2.8.so.0
>     libwx_baseu_xml-2.8.so.0 =>     /usr/lib/libwx_baseu_xml-2.8.so.0
>     libwx_baseu_net-2.8.so.0 =>     /usr/lib/libwx_baseu_net-2.8.so.0
>     libwx_baseu-2.8.so.0 =>     /usr/lib/libwx_baseu-2.8.so.0
>     libxml2.so.2 =>     /usr/lib/libxml2.so.2
>     libz.so.1 =>     /usr/lib/libz.so.1
>     libpthread.so.1 =>     /usr/lib/libpthread.so.1
>     libsocket.so.1 =>     /usr/lib/libsocket.so.1
>     libxslt.so.1 =>     /usr/lib/libxslt.so.1
>     libm.so.2 =>     /usr/lib/libm.so.2
>     libpq.so.5 =>     /usr/local/pgsql/lib/libpq.so.5
>     libstdc++.so.6 =>     /usr/sfw/lib/libstdc++.so.6
>     libgcc_s.so.1 =>     /usr/sfw/lib/libgcc_s.so.1
>     libc.so.1 =>     /usr/lib/libc.so.1
>     libcrypto.so.0.9.8 =>     /lib/libcrypto.so.0.9.8
>     libmp.so.2 =>     /lib/libmp.so.2
>     libmd.so.1 =>     /lib/libmd.so.1
>     libCstd.so.1 =>     /usr/lib/libCstd.so.1
>     libgtk-x11-2.0.so.0 =>     /usr/lib/libgtk-x11-2.0.so.0
>     libsecdb.so.1 =>     /usr/lib/libsecdb.so.1
>     libtsol.so.2 =>     /usr/lib/libtsol.so.2
>     libgdk-x11-2.0.so.0 =>     /usr/lib/libgdk-x11-2.0.so.0
>     libatk-1.0.so.0 =>     /usr/lib/libatk-1.0.so.0
>     libpangoft2-1.0.so.0 =>     /usr/lib/libpangoft2-1.0.so.0
>     libgdk_pixbuf-2.0.so.0 =>     /usr/lib/libgdk_pixbuf-2.0.so.0
>     libXext.so.0 =>     /usr/lib/libXext.so.0
>     libXrender.so.1 =>     /usr/lib/libXrender.so.1
>     libXinerama.so.1 =>     /usr/lib/libXinerama.so.1
>     libXi.so.5 =>     /usr/lib/libXi.so.5
>     libXrandr.so.2 =>     /usr/lib/libXrandr.so.2
>     libXcursor.so.1 =>     /usr/lib/libXcursor.so.1
>     libXcomposite.so.1 =>     /usr/lib/libXcomposite.so.1
>     libXdamage.so.1 =>     /usr/lib/libXdamage.so.1
>     libgio-2.0.so.0 =>     /usr/lib/libgio-2.0.so.0
>     libXfixes.so.1 =>     /usr/lib/libXfixes.so.1
>     libX11.so.4 =>     /usr/lib/libX11.so.4
>     libpango-1.0.so.0 =>     /usr/lib/libpango-1.0.so.0
>     libfreetype.so.6 =>     /usr/lib/libfreetype.so.6
>     libfontconfig.so.1 =>     /usr/lib/libfontconfig.so.1
>     libgobject-2.0.so.0 =>     /usr/lib/libgobject-2.0.so.0
>     libgmodule-2.0.so.0 =>     /usr/lib/libgmodule-2.0.so.0
>     libgthread-2.0.so.0 =>     /usr/lib/libgthread-2.0.so.0
>     libthread.so.1 =>     /usr/lib/libthread.so.1
>     libglib-2.0.so.0 =>     /usr/lib/libglib-2.0.so.0
>     libXxf86vm.so.1 =>     /usr/lib/libXxf86vm.so.1
>     libSM.so.6 =>     /usr/lib/libSM.so.6
>     libjpeg.so.62 =>     /usr/lib/libjpeg.so.62
>     libtiff.so.3 =>     /usr/lib/libtiff.so.3
>     libSDL-1.2.so.0 =>     /usr/lib/libSDL-1.2.so.0
>     libexpat.so.1 =>     /usr/lib/libexpat.so.1
>     libCrun.so.1 =>     /usr/lib/libCrun.so.1
>     libpangocairo-1.0.so.0 =>     /usr/lib/libpangocairo-1.0.so.0
>     libcairo.so.2 =>     /usr/lib/libcairo.so.2
>     libresolv.so.2 =>     /lib/libresolv.so.2
>     libXau.so.6 =>     /usr/lib/libXau.so.6
>     libXdmcp.so.6 =>     /usr/lib/libXdmcp.so.6
>     libICE.so.6 =>     /usr/lib/libICE.so.6
>     libesd.so.0 =>     /usr/lib/libesd.so.0
>     librt.so.1 =>     /lib/librt.so.1
>     libpixman-1.so.0 =>     /usr/lib/libpixman-1.so.0
>     libpng12.so.0 =>     /usr/lib/libpng12.so.0
>     libaudiofile.so.0 =>     /usr/lib/libaudiofile.so.0
>     mech_krb5.so.1 =>     /usr/lib/gss/mech_krb5.so.1
>     libgss.so.1 =>     /usr/lib/libgss.so.1
>     libpkcs11.so.1 =>     /usr/lib/libpkcs11.so.1
>     libkstat.so.1 =>     /lib/libkstat.so.1
>     libcryptoutil.so.1 =>     /lib/libcryptoutil.so.1
>     libscf.so.1 =>     /lib/libscf.so.1
>     libuutil.so.1 =>     /lib/libuutil.so.1
>     libgen.so.1 =>     /lib/libgen.so.1
>     libnvpair.so.1 =>     /lib/libnvpair.so.1
>     libsmbios.so.1 =>     /usr/lib/libsmbios.so.1
>     libXevie.so.1 =>     /usr/lib/libXevie.so.1
>     libXss.so.1 =>     /usr/lib/libXss.so.1
>
>
>
> On 12/20/10 05:08 PM, Ashesh Vashi wrote:
>
> What is the output of 'ldd pgadmin3'?
>
>   --
> Thanks & Regards,
>
> Ashesh Vashi
> EnterpriseDB INDIA: Enterprise Postgres Company<http://www.enterprisedb.com>
>
>
>
> *http://www.linkedin.com/in/asheshvashi*<http://www.linkedin.com/in/asheshvashi>
>
>
> On Mon, Dec 20, 2010 at 5:25 AM, Peter Oram <peter(dot)oram(at)dodo(dot)com(dot)au>wrote:
>
>>  I have successfully rebuilt wxWidgets using the build-wxgtk script, then
>> rebuilt pgAdmin3. However, once again when I try to run the pgAdmin3
>> application I am still getting the same relocation error as before.
>>
>> Now I have two versions of wxWidgets installed on the system. The original
>> version that was installed as part of the OS - version 2.8.10 which was
>> installed to /usr/include/wx-2.8 and now the latest version which has been
>> installed in /usr/local/include/wx-2.8 (this is version 2.8.11).
>>
>> Configure as part of pgadmin3 install process found the newer version.
>>
>> Peter Oram
>>
>>
>> On 12/17/10 04:34 PM, Ashesh Vashi wrote:
>>
>> Hi Peter,
>>
>> Please use the script 'xtra/wx-build/build-wxgtk' found under pgadmin
>> source directory to build the wxGTK/wxWidgets.
>> i.e. (with root)
>> /bin/bash <pgAdmin_source_path>/xtra/wx-build/build-wxgtk
>> <wxGTK_source_dir>
>>
>> The error suggests that stc (wxStyledText) is not installed from the
>> contrib module of wxGTK.
>>
>>   --
>> Thanks & Regards,
>>
>> Ashesh Vashi
>> EnterpriseDB INDIA: Enterprise Postgres Company<http://www.enterprisedb.com>
>>
>>
>>
>> *http://www.linkedin.com/in/asheshvashi*<http://www.linkedin.com/in/asheshvashi>
>>
>>
>> On Fri, Dec 17, 2010 at 9:37 AM, Peter Oram <peter(dot)oram(at)dodo(dot)com(dot)au>wrote:
>>
>>>  I am attempting to install pgAdmin3 version 1.12.1 on an Oracle Solaris
>>> 11 Express 2010.11 system.
>>>
>>> I have the recommended version of GTK2, GNU automake, autoconf and gcc
>>> installed as part of my development environment.
>>>
>>> I have updated the wxGTK package to 2.8.11, and also have above the
>>> recommended versions of libxml2, libcslt.
>>>
>>> I have also installed PostgreSQL 9.0.1 on my system. All the above
>>> installed without errors, either as an installed package of the OS or from
>>> source, such as wxGTK and PostgreSQL.
>>>
>>> pgAdmin3 installed without errors, but when I try to run the application,
>>> I get the following error:
>>>
>>>    ld.so.1: pgadmin3: fatal: relocation error: file
>>> /usr/local/pgadmin3/bin/pgadmin3: symbol _ZTI16wxStyledTextCtrl: referenced
>>> symbol not found
>>>
>>> Note: PostgreSQL was installed using the "--with-openssl" configure
>>> option.
>>> wxGTK was installed with the "--with-gtk --enable-gtk2 --enable-unicode
>>> --enable-mimetype=no --enable-shared --enable-debug --disable-gtktest"
>>> configure options.
>>> The current default library path is set to:
>>> /lib:/usr/lib:/usr/local/lib:/usr/sfw/lib:/usr/local/pgsql/lib:/usr/ccs/lib:/usr/dt/lib:/usr/gnu/lib/usr/X11/lib
>>>
>>> --
>>> Sent via pgadmin-support mailing list (pgadmin-support(at)postgresql(dot)org)
>>> To make changes to your subscription:
>>> http://www.postgresql.org/mailpref/pgadmin-support
>>>
>>
>>
>

In response to

pgadmin-support by date

Next:From: Dave PageDate: 2010-12-20 09:21:50
Subject: Re: [BUGS] BUG #5791: Tables are not viewing through pgadmin
Previous:From: Peter OramDate: 2010-12-20 06:27:59
Subject: Re: Problem installing pgadmin3-1.12.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group