Skip site navigation (1) Skip section navigation (2)

Re: ERROR: argument to pg_get_expr() must come from system catalogs

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Bruce Momjian <bruce(at)momjian(dot)us>
Cc: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Heikki Linnakangas <heikki(dot)linnakangas(at)enterprisedb(dot)com>, PostgreSQL Hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: ERROR: argument to pg_get_expr() must come from system catalogs
Date: 2010-07-28 15:58:29
Message-ID: AANLkTikMDGrPn=VPTuyDO6GTjts1cmOj-uHwHZsU3aD+@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Wed, Jul 28, 2010 at 4:54 PM, Bruce Momjian <bruce(at)momjian(dot)us> wrote:
> Are we basically leaving pgAdmin in this state until we come up with a
> fix and need a new minor release?  We pride ourselves in not introducing
> breakage in minor releases, but it has certainly happened in this case,
> and it is making pgAdmin look bad.  Dave, is there a hack you can add to
> pgAdmin to work around the join issue until we can fix the backend?

It wouldn't make much difference if there was - the majority of people
won't get it until they upgrade their server anyway.


-- 
Dave Page
EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise Postgres Company

In response to

pgsql-hackers by date

Next:From: Jeff DavisDate: 2010-07-28 16:12:41
Subject: Re: page corruption on 8.3+ that makes it to standby
Previous:From: Bruce MomjianDate: 2010-07-28 15:54:52
Subject: Re: ERROR: argument to pg_get_expr() must come from system catalogs

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group