Skip site navigation (1) Skip section navigation (2)

Re: Error instalando slony-I

From: Xavier Emilio Guerra Rodriguez <tomrero(at)gmail(dot)com>
To: Jaime Casanova <jaime(at)2ndquadrant(dot)com>
Cc: ayuda de postgres en español <pgsql-es-ayuda(at)postgresql(dot)org>
Subject: Re: Error instalando slony-I
Date: 2011-01-29 11:31:42
Message-ID: AANLkTi=t0TzBvGAvk3n0Sn6SKdEo5i2C7B26LaLeZL8b@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Hola Jaime:

Si el error es al ejecutar el configure de slony, con la instalación de
postgres no hay ningún problema

estoy instalando slony desde la fuentes la version 2.0.6 me estoy guiando
por el  archivo
install de los fuentes, de modo que estoy aplicando el ./configure de la
siguiente manera:

./configure --with-pgconfigdir=/PATH/donde_encuentra_el_pgconfig

y me genera el error que mencione antes, en el archivo install dice que en
ciertas platamormas
postgres se tuvo que haber configurado con la opcion --enable-thread-safety
por eso al
estoy usando esas opciones en la configuración de postgres el cual instalo
sin ningún problema.

intente instalar slony en un servidor que ya tiene postgres
instalado desde las fuentes sin la opción --enable-thread-safety, e igual me
da el error

El 29 de enero de 2011 23:05, Jaime Casanova <jaime(at)2ndquadrant(dot)com>escribió:

> 2011/1/28 Xavier Emilio Guerra Rodriguez <tomrero(at)gmail(dot)com>:
> > Buenas Tardes Lista:
> >
> > el error que me da es el siguiente:
> >
> > PostgreSQL for thread-safety... configure: error: PQisthreadsafe test
> failed
> > - PostgreSQL needs to be compiled with --enable-thread-safety
> >
>
> imagino que este error es de slony, verdad?
>
> > Estoy instalando postgres version 8.4.1 desde los fuentes en centos 5.5
> >
> > asi aplíco la compilación:
> >
> > ./configure --prefix=/usr/local/ --enable-nls --with-perl --with-openssl
> > --with-pam --enable-thread-safety
> >
>
> esto no te da ningun error? imagino que luego de hacer esto haces make
> y make install, verdad?
>
> > y aun así me da el error al instalar slony-I la version que estoy
> instalando
> > es la 2.0.6
> >
>
> y como estas compilando slony? o estas instalando alguno ya compilado?
>
> --
> Jaime Casanova         www.2ndQuadrant.com
> Professional PostgreSQL: Soporte y capacitación de PostgreSQL
>

In response to

pgsql-es-ayuda by date

Next:From: Edwin Perez LozanoDate: 2011-01-29 21:15:51
Subject: Re: [pgsql-es-ayuda] comando psql y crear usuario si?==?ISO-8859-1?Q?n contraseña postgres
Previous:From: Jaime CasanovaDate: 2011-01-29 03:43:44
Subject: Re: Como podria obtener el DDL de cada objeto como lo hace pgadmin?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group