Skip site navigation (1) Skip section navigation (2)

Re: Postgres y Versiones.

From: Cristian Herrera <cristian(dot)ruztort(at)gmail(dot)com>
To: "Ing(dot) Marcos Ortiz Valmaseda" <mlortiz(at)uci(dot)cu>
Cc: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: Postgres y Versiones.
Date: 2011-02-11 14:06:06
Message-ID: AANLkTi=mr2Ge=AbP2JEerSx3m_F17k+hR96dDvKsvT1A@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Gracias por la respuesta,
bueno de hecho la maquina nueva tiene ubuntu server 10.10, postgres 8.4.7 y
PHP 5.3.3.

Voy a intentar subir primero de 7.4 a 8.0 y ver como funciona.

Saludos
Cristian.

El 11 de febrero de 2011 10:49, Ing. Marcos Ortiz Valmaseda
<mlortiz(at)uci(dot)cu>escribió:

> Creo que hay demasiados releases entre estas dos versiones. Pudieras bajar
> un poco de versiones y hacer una migración paulatina entre 7.4 y 8.0, y
> luego que ya estés en la rama 8.X, prueba hacer la migración primero a 8.2,
> y luego a 8.4.
>
> Mi recomendación es que hagas la migración hasta la última versión: 9.0.3,
> que presenta muchas mejoras y correcciones de seguridad desde el release de
> 9.0.0
>
> Otra recomendación es que instales una versión más actualizada de tu
> sistema operativo (Ubuntu ya va por la versión 10.10), para que así sea más
> fácil la instalación de paquetes, tengas un kernel actualizado compatible
> con más dispositivos y además con las actualizaciones de seguridad al día.
>
> La última versión de PHP es la 5.3.3, y mi recomendación es que pruebes
> primero con la versión 5.2, porque entre estas dos hay varias
> incompatibilidades.
>
> Saludos y suerte en la acometida.
> ----- Mensaje original -----
> De: "Cristian Herrera" <cristian(dot)ruztort(at)gmail(dot)com>
> Para: pgsql-es-ayuda(at)postgresql(dot)org
> Enviados: Viernes, 11 de Febrero 2011 8:29:39 GMT -05:00 Región oriental
> EE. UU./Canadá
> Asunto: [pgsql-es-ayuda] Postgres y Versiones.
>
> Buenas.
>
>
> Tengo una maquina que tiene Postgres 7.4, es una maquina antigua (Ubuntu 5)
> + PHP4, esta maquina tiene un sistema administrativo que funciona bien, el
> cuento es que acaban de comprar equipos nuevos por lo cual deseo subir de
> version a Postgres 8.4 y PHP5, hice un pg_dump y pg_restore el cual dio
> problemas por los oid's revisando la documentacion cambie la opcion de
> compatibilidad (default_with_oids = on) con lo cual no genero errores al
> hacer la restauracion, hasta ahi todo bien, al montar el SIA y hacerlo
> funcionar genera varios errores de postgres como Operadores que no existen,
> conversiones explicitas de tipos, entre otros, mi pregunta es posible una
> compatibilidad entre 7.4 y 8.4 sin cambiar mucho codigo? El SIA tiene un
> codigo "horrible" el cual no conozco y llevaria un tiempo considerable
> revisarlo todo y hacer los cambios para la compatibilidad lo cual se hará en
> paralelo.
>
>
> Gracias por el tiempo.
> Saludos
>
>
> Cristian.
>
> --
> Ing. Marcos Luís Ortíz Valmaseda
> System Engineer -- Database Administrator
>
> Centro de Tecnologías de Gestión de Datos (DATEC)
> Universidad de las Ciencias Informáticas
> http://postgresql.uci.cu
>
>

In response to

pgsql-es-ayuda by date

Next:From: Alvaro HerreraDate: 2011-02-11 14:07:07
Subject: Re: Postgres y Versiones.
Previous:From: Ing. Marcos Ortiz ValmasedaDate: 2011-02-11 13:49:55
Subject: Re: Postgres y Versiones.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group