2010/10/25 Andrew Dunstan <andrew(at)dunslane(dot)net>:
> On 10/25/2010 02:51 PM, Robert Haas wrote:
>> On Mon, Oct 25, 2010 at 2:41 PM, Tom Lane<tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
>>> "David E. Wheeler"<david(at)kineticode(dot)com> writes:
>>>> On Oct 25, 2010, at 10:08 AM, Tom Lane wrote:
>>>>> I can see the point of that, but I don't find LABEL to be a
>>>>> great name for the elements of an enum type, and so I'm not in favor of
>>>>> institutionalizing that name in the syntax. How about ADD VALUE?
>>>> So the docs have called them "labels" for quite some time.
>>> There are some places in the docs that use that term, but there are
>>> others that don't. In any case, using the term in the SQL syntax
>>> casts it in stone, not silly putty ...
>> Personally, I prefer LABEL. But I could live with VALUE.
> That's roughly my position. It would be consistent with the name we use in
> the catalogs, as well as what's in the docs. I don't think it's as opaque as
> Tom seems to suggest. An enum is pretty much an ordered set of labels. But I
> could certainly live with VALUE if that's the consensus.
I agree with you. There are some better keywords than VALUE - maybe
ELEMENT or just LABEL. I understand if there must be a reserved
keyword - but if not I prefer LABEL too.
> Sent via pgsql-hackers mailing list (pgsql-hackers(at)postgresql(dot)org)
> To make changes to your subscription:
In response to
pgsql-hackers by date
|Next:||From: Tom Lane||Date: 2010-10-25 20:09:20|
|Subject: Re: Floating-point timestamps versus Range Types |
|Previous:||From: David Fetter||Date: 2010-10-25 20:01:23|
|Subject: Tab completion for view triggers in psql|