Skip site navigation (1) Skip section navigation (2)

Re: PGAdmin - still no jobs node.

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Piotr Czekalski <pczekalski(at)techbaza(dot)pl>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: PGAdmin - still no jobs node.
Date: 2010-11-15 17:01:04
Message-ID: AANLkTi=Ch7=8UbXEaKhmFtKkVChKG5EYj6DHpk62i6Du@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
On Mon, Nov 15, 2010 at 4:52 PM, Piotr Czekalski <pczekalski(at)techbaza(dot)pl> wrote:
> W dniu 2010-11-15 14:46, Dave Page pisze:
>>
>> On Mon, Nov 15, 2010 at 1:09 PM, Piotr Czekalski<pczekalski(at)techbaza(dot)pl>
>>  wrote:
>>>
>>> I've installed the PgAgent over PostgreSQL 8.4.2(already running for few
>>> months), on Fedora 12 (x64) OS. The DB by itself works perfect. The
>>> script
>>> was taken from the Fedora's distro, running:
>>> ./psql -h<hostip>  -d postgres --user postgres -f
>>> /usr/local/pgadmin3/share/pgadmin3/pgagent.sql and returned no errors
>>> (just
>>> warnings on creation of few sequences).
>>> The schema has been created in Postgres (management) database but still
>>> PgAdmin (1.12.1) shows only PgAgent under Catalogue node, there is no
>>> visible pgagent schema under Schema's node nor Jobs node to manage jobs.
>>> When I try to create pgagent schema it says such a schema already exists
>>> (which I believe is true).
>>> The user connecting to database is Postgres with DBA right thus I believe
>>> this is not a security problem, however.
>>
>> Can you confirm that the management database in pgAdmin is set to the
>> postgres database for the appropriate server?
>>
>>
>>
> Yes - it is set to 'Postgres'.
> I've already tried to manage jobs both on Postgres database and second one
> with management set to 'Postgres' but in both cases there is no luck.
>
> Anything else can I do or check to make it working?

The mere existence of the pgAgent schema (and a couple of the objects
in it) in the maintenance database should make the jobs node show up,
regardless of the rest of the pgAgent configuration. The fact that you
say it doesn't show up under "Catalogs" either makes me think that
you're looking in the wrong database or server, or, you accidentally
installed it in the wrong database or server.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

In response to

Responses

pgadmin-support by date

Next:From: Piotr CzekalskiDate: 2010-11-15 17:15:49
Subject: Re: PGAdmin - still no jobs node.
Previous:From: Piotr CzekalskiDate: 2010-11-15 16:52:52
Subject: Re: PGAdmin - still no jobs node.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group