Skip site navigation (1) Skip section navigation (2)

Re: Issue with libpq < 8.4

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Magnus Hagander <magnus(at)hagander(dot)net>
Cc: Guillaume Lelarge <guillaume(at)lelarge(dot)info>, pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: Issue with libpq < 8.4
Date: 2010-08-24 11:45:50
Message-ID: AANLkTi=5Ww76BpOn-FBNvd0gZixZTdt4Yk=Fdex4DC37@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-hackers
On Tue, Aug 24, 2010 at 12:41 PM, Magnus Hagander <magnus(at)hagander(dot)net> wrote:
> So can't we do something like:
>
> #ifdef HAVE_CONNINFO_PARSE
> if (conninfoparse_shows_we_have_application_name_support)
>   use connstr_with_appname;
> else
>   use connstr_without_appname;
> #else
>   use connstr_without_appname
> #endif
>
> ? That way it should still work with older libpq, just not set
> application_name...

That would probably work. We should probably have a runtime check for
Windows, as we do for the EDB libpq functions.

When can I expect the patch?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise Postgres Company

In response to

Responses

pgadmin-hackers by date

Next:From: Magnus HaganderDate: 2010-08-24 11:48:53
Subject: Re: Issue with libpq < 8.4
Previous:From: Magnus HaganderDate: 2010-08-24 11:41:35
Subject: Re: Issue with libpq < 8.4

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group