On Feb 24, 2011, at 10:43 AM, Robert Haas wrote:
>> The best idea I have at the moment is to spell out "data modifying
>> command" (or "statement") rather than relying on the acronym.
>> In the code, we could change hasDmlWith to hasModifyingWith, for
>> example. The error messages could read like
>> data-modifying statement in WITH is not allowed in a view
> Great idea. I had the same complaint when I looked at this patch a
> year ago, but didn't come up with nearly as good an idea as to what to
> do about it.
I like "statement" better than "command," too, but love the acronym DMC. As in, "you want to Run [a] DMC." ;-P
In response to
pgsql-hackers by date
|Next:||From: Radosław Smogura||Date: 2011-02-24 20:02:06|
|Subject: Re: Binary in/out for aclitem|
|Previous:||From: Robert Haas||Date: 2011-02-24 18:43:13|
|Subject: Re: wCTE: about the name of the feature|