Skip site navigation (1) Skip section navigation (2)

Re: [GENERAL] pg_dump: aborting because of version mismatch

From: Magnus Hagander <magnus(at)hagander(dot)net>
To: "Net Tree Inc(dot)" <nettreeinc(at)gmail(dot)com>
Cc: pgsql-admin <pgsql-admin(at)postgresql(dot)org>, pgsql-general <pgsql-general(at)postgresql(dot)org>
Subject: Re: [GENERAL] pg_dump: aborting because of version mismatch
Date: 2010-02-23 10:56:53
Message-ID: 9837222c1002230256y4f8cdc10pc8759ed294119704@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-adminpgsql-general
2010/2/23 Net Tree Inc. <nettreeinc(at)gmail(dot)com>:
> Thanks..
> This is what I am confused about. I installed a ver. 8.4 postgresql, why it's pg_dump is 8.3.9?? For first one, how could this possibly having problem using pg_dump that comes with the server install??

Comes with what server install? It depends on how you install
PostgreSQL, and on what platform you are. But clearly you are using a
pg_dump that comes from a previous version. It could be that you have
both installed, but that the 8.3 version comes first in your PATH
perhaps?

> the first one I backup using pgAdmin III ver. 1.8.4 on a ver 8.3.9 postgreSQL server

pgadmin ships with a copy of pg_dump. 1.8 ships with pg_dump from 8.3,
so -i should work there. pgadmin 1.8 isn't supported with server 8.4
at all anyway, so you need pgadmin 1.10 for that - which ships with
pg_dump from 8.4.

> the second one I backup using command line on a ver 8.4 postgreSQL server
> Is this something that can solved by upgrade or reinstall ver. 8.4 of  pg_dump?
> Is that its only downward compatible but not upward? which mean I can do restore on 8.4 from backup created by ver 8.3 pg_dump, but probably won't work the other way around? Definitely impossible? then what is '-i' use for.....?

No. You can restore on 8.4 only if you used pg_dump 8.4. But you ca
nuse pg_dump 8.4 on 8.3 just fine.

-i really is for minor versions only. And due to the fact that it's
not really useful, it's been removed (well the option is there, but it
doesn't do anything) in 8.4.
-- 
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/

In response to

pgsql-admin by date

Next:From: Iñigo Martinez LasalaDate: 2010-02-23 11:03:01
Subject: Re: how do I do dump and restore without bugging with constraint?
Previous:From: Net Tree Inc.Date: 2010-02-23 10:34:11
Subject: Re: [GENERAL] pg_dump: aborting because of version mismatch

pgsql-general by date

Next:From: Iñigo Martinez LasalaDate: 2010-02-23 11:03:01
Subject: Re: how do I do dump and restore without bugging with constraint?
Previous:From: Carsten KropfDate: 2010-02-23 10:53:33
Subject: Re: Implementing an Index Access Method in PG 8.4

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group