Skip site navigation (1) Skip section navigation (2)

Re: Can't compile psqlodbc on Solaris 8

From: "Michael E(dot) Laws" <mike(at)landwinc(dot)com>
To: <pgsql-odbc(at)postgresql(dot)org>
Subject: Re: Can't compile psqlodbc on Solaris 8
Date: 2005-01-03 12:35:52
Message-ID: 948839ACFA537042B39DF75FA5CA701A3772@server1.landwinc.com (view raw or flat)
Thread:
Lists: pgsql-odbc
 --- "Celeste Suliin Burris" <csburris(at)ci(dot)tacoma(dot)wa(dot)us> wrote:
> When I try to compile psqlodbc on Solaris 8, it fails. I'm not sure
> what I'm doing wrong. gcc version 3.4.0 GNU libtool 1.4.2
> GNU Make 3.80
> solaris 8 linker on Solaris 8 sparc.
>
> configured with the options - --enable-shared --with-iodbc
> --with-odbcinst=/usr/local/etc
>
> errors look like this -
>
> source='environ.c' object='environ.lo' libtool=yes \
> depfile='.deps/environ.Plo' tmpdepfile='.deps/environ.TPlo' \ 
> depmode=gcc3 /bin/sh ./depcomp \ /bin/sh ./libtool --mode=compile gcc 
> -DHAVE_CONFIG_H -I. -I. -I. -g -O2 -c -o environ.lo `test -f 
> 'environ.c' || echo './'`environ.c gcc -DHAVE_CONFIG_H -I. -I. -I. -g 
> -O2 -c environ.c -MT environ.lo -MD -MP -MF .deps/environ.TPlo -fPIC
-DPIC -o environ.lo
> environ.c:233: error: conflicting types for 'PGAPI_StmtError'
> pgapifunc.h:78: error: previous declaration of 'PGAPI_StmtError' was
here
> environ.c:233: error: conflicting types for 'PGAPI_StmtError'
> pgapifunc.h:78: error: previous declaration of 'PGAPI_StmtError' was
here
> environ.c:465: error: conflicting types for 'PGAPI_ConnectError'
> pgapifunc.h:74: error: previous declaration of 'PGAPI_ConnectError'
was here
> environ.c:465: error: conflicting types for 'PGAPI_ConnectError'
> pgapifunc.h:74: error: previous declaration of 'PGAPI_ConnectError'
was here
> environ.c:598: error: conflicting types for 'PGAPI_EnvError'
> pgapifunc.h:70: error: previous declaration of 'PGAPI_EnvError' was
here
> environ.c:598: error: conflicting types for 'PGAPI_EnvError'
> pgapifunc.h:70: error: previous declaration of 'PGAPI_EnvError' was
here
> environ.c:660: error: conflicting types for 'PGAPI_Error'
> pgapifunc.h:65: error: previous declaration of 'PGAPI_Error' was here
> environ.c:660: error: conflicting types for 'PGAPI_Error'
> pgapifunc.h:65: error: previous declaration of 'PGAPI_Error' was here
> gmake[1]: *** [environ.lo] Error 1
> gmake[1]: Leaving directory `/tools/database/PostgreSQL/psqlodbc'
> gmake: *** [all] Error 2

I'm relatively new to the PostgreSQL ODBC driver so take this for what
it's worth...

On Solaris 9 (SPARC) with a similar configuration, I received the same
errors you did using iODBC 3.52.1.  After seeing some of the same errors
when compiling OpenLDAP (using iODBC), I switched to iODBC 3.51.2 and
PostgreSQL ODBC compiled just fine.  I haven't fully tested yet so
please let us know how it goes!

Regards,
Michael Laws

pgsql-odbc by date

Next:From: innenka innenkaDate: 2005-01-03 21:56:21
Subject: error de ODBC
Previous:From: Michael E. LawsDate: 2005-01-03 12:31:25
Subject: Re: Can't compile psqlodbc on Solaris 8

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group