Skip site navigation (1) Skip section navigation (2)

Re: Installing on Mac OS X 10.1

From: Jim Dickenson <dickenson(at)cfmc(dot)com>
To: pgsql-odbc(at)postgresql(dot)org
Subject: Re: Installing on Mac OS X 10.1
Date: 2001-10-05 22:59:07
Message-ID: (view raw or whole thread)
Lists: pgsql-odbc
On Thursday, October 4, 2001, at 03:13  PM, Jim Dickenson wrote:

> I am trying to get ODBC working under OS X 10.1. I have not been able 
> to compile unixODBC or iODBC because of link errors. I did find a 
> binary install for iODBC on their site.
> I tried to compile the current version fo MyODBC but the host type is 
> unknown so it will not compile.
> I installed PostgreSQL as it comes with ODBC drivers and when I try to 
> connect I get the following errors:
> (null)(5): Invalid access (permissions?)
> [iODBC][Driver Manager]Dialog failed, SQLSTATE=IM008
> My preference would be to install MyODBC and use MySQL as well as 
> unixODBC as this is what I develop with under Linux.
> Can anyone help me get any or all of this stuff working under OS X?

Nick Gorham from EasySoft was very helpful in getting unixODBC and the 
ODBC driver for PostgreSQL working under OS X 10.1. is a 
link to the source I used. Read the OSX readme file because, for me at 
least, I had to install dlcompat-20010831.tar.gz to make it work.

Thanks Nick!

Jim Dickenson

Computers for Marketing Corporation

eFax: 1-419-791-8924

In response to

pgsql-odbc by date

Next:From: Peter DrahosDate: 2001-10-07 07:59:40
Subject: Please HELP ODBC connection problems
Previous:From: Jim DickensonDate: 2001-10-04 22:13:54
Subject: Installing on Mac OS X 10.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group