Skip site navigation (1) Skip section navigation (2)

WAL DUDAS

From: Antonio Perez <renjin25(at)yahoo(dot)com>
To: pgsql-performance(at)postgresql(dot)org
Subject: WAL DUDAS
Date: 2008-06-18 19:43:51
Message-ID: 941965.84339.qm@web56212.mail.re3.yahoo.com (view raw or flat)
Thread:
Lists: pgsql-es-ayudapgsql-performance
Tengo una pregunta, y este es el escenario de lo que tengo





	 
	
	
	
	
	

Se crea una instancia de
	postgreSQL
	Se crea un directorio
	$PGDATA/walback donde se almacenararn los wal antiguos
	Se exporta una variable $PGDATA2
	que es la ubicacion del respaldo del contenido de $PGDATA
	Se activa el wal
	Se crea una BD y una tabla
	En psql  se ejecuta
	pg_start_backup('etiqueta');
	Se realiza una copia de todo lo
	que esta en $PGDATA hacia otro directorio ($PGDATA2)
	En psql  se ejecuta
	pg_stop_backup();
	Se actualiza el valor de un
	registro en la tabla que se creo
	Se baja la instancia
	Se copia todo el contenido de
	$PGDATA/pg_xlog y $PGDATA/walback en $PGDATA2/pg_xlog y
	$PGDATA2/walback
	Se inicia la instancia con pg_ctl
	-D $PGDATA2 --log $PGDATA2/log.log start
	Se ejecuta psql
	Se consulta la tabla y no existen
	registro
	
	Si alguien sabe el porque pasa esto me
	avisan. Gracias

Responses

pgsql-performance by date

Next:From: Jaime CasanovaDate: 2008-06-18 23:19:06
Subject: Re: [PERFORM] WAL DUDAS
Previous:From: CiskoDate: 2008-06-18 16:18:00
Subject: Partial backup of linked tables

pgsql-es-ayuda by date

Next:From: Luis D. GarcíaDate: 2008-06-18 20:36:20
Subject: Re: Postgresql 8.3
Previous:From: Alvaro HerreraDate: 2008-06-18 19:17:54
Subject: Re: Prueba de encoding LATIN9 (falla en pgadminIII) ??

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group