Skip site navigation (1) Skip section navigation (2)

Re: pgAdmin III v1.10.2 released

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Dale J Thompson <Dale(dot)J(dot)Thompson(at)noaa(dot)gov>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: pgAdmin III v1.10.2 released
Date: 2010-03-18 08:55:37
Message-ID: 937d27e11003180155w43305beao375e9e0a70a16688@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
On Wed, Mar 17, 2010 at 5:46 PM, Dale J Thompson
<Dale(dot)J(dot)Thompson(at)noaa(dot)gov> wrote:
> I apologize for assuming this was a well known problem.
>
> If it's not feasible to adjust the build to work around this issue, I'd
> suggest the documentation for pgAdmin be updated to clarify that it requires
> 8.3(?) or greater version of postgresql to build. It's certainly not
> reasonable to assume people will be willing to remove their vendor provided
> and supported versions of postgresql, but this documentation update would
> help people to know they need to build a 1.10.0 version if they use Redhat
> 5. That's the rpm I build for my userbase and it mostly works fine.

Oh, sorry - my comments were aimed at the other devs. They probably
seemed a bit harsh from your perspective.

The problem is that but restricting ourselves to support of older
versions of libpq, we either lose out on important functionality for
may years, or we have to build pgAdmin in such a way that features get
enabled or disabled based on the version of libpq in use, which leads
to an inconsistent experience that many users won't understand, and
makes it harder to debug problems that crop up.

Limiting ourselves to a modern libpq shouldn't be an issue for a
number of reasons:

- it's versioned, so updating it on a machine should not be an issue
if an older version is already installed.
- most users that want a modern pgAdmin will probably use a package
repository that offers them that and also the newer PostgreSQL.
- In the worst case scenario, users can always statically link with a
private copy of the newer version, or install into a private directory
and include the newer libpq there.

The docs were out of date though - I've fixed that now.

> By the way, my users where specifically looking for the graphical query
> builder, which was my reason for looking into version 1.10.x of pgAdmin.

It might be slightly more of a pain to build/distribute if you have
vendor packages for 8.1 installed that you do not wish to touch, but
it shouldn't be an insurmountable problem.

-- 
Dave Page
EnterpriseDB UK: http://www.enterprisedb.com
PG East Conference: http://www.enterprisedb.com/community/nav-pg-east-2010.do

In response to

Responses

pgadmin-support by date

Next:From: Vinicius BorgesDate: 2010-03-18 10:34:45
Subject: Re: Problem with libpq.so.5 in pgadmin3-1.10.2
Previous:From: Ashesh VashiDate: 2010-03-18 06:48:23
Subject: Re: Problem with libpq.so.5 in pgadmin3-1.10.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group