Skip site navigation (1) Skip section navigation (2)

Re: pgAdmin - no_spool

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Pedro Doria Meunier <pdoria(at)netmadeira(dot)com>
Cc: pgAdmin Support <pgadmin-support(at)postgresql(dot)org>
Subject: Re: pgAdmin - no_spool
Date: 2009-07-01 09:07:32
Message-ID: 937d27e10907010207iafcc342g1ae0f6d70e463af5@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
On Wed, Jul 1, 2009 at 9:12 AM, Pedro Doria
Meunier<pdoria(at)netmadeira(dot)com> wrote:
> Hi Dave,
>
> Could you please tell me why when I click on a cluster pgAdmin
> exhibits a dialog stating:
> "Column not found in pgSet: no_spool" ?
>
> - pgAdmin version 1.10.0 Beta2 rev. 7749
> - Slony ver 2.0.2
> - Master on a remote server
> - Slony-I not installed on localhost (could it be it?!)

I guess noone tried Slony 2.0 yet :-(. Please try the patch below:

Index: pgadmin/slony/slNode.cpp
===================================================================
--- pgadmin/slony/slNode.cpp	(revision 7945)
+++ pgadmin/slony/slNode.cpp	(working copy)
@@ -287,7 +287,10 @@
             node->iSetComment(nodes->GetVal(wxT("no_comment")));

             if (collection->GetCluster()->ClusterMinimumVersion(1,1))
-                node->iSetSpool(nodes->GetBool(wxT("no_spool")));
+            {
+                if (nodes->HasColumn(wxT("no_spool")))
+                    node->iSetSpool(nodes->GetBool(wxT("no_spool")));
+            }

             if (browser)
             {



-- 
Dave Page
EnterpriseDB UK:   http://www.enterprisedb.com

In response to

Responses

pgadmin-support by date

Next:From: Pedro Doria MeunierDate: 2009-07-01 14:00:32
Subject: Re: pgAdmin - no_spool
Previous:From: Pedro Doria MeunierDate: 2009-07-01 08:12:55
Subject: pgAdmin - no_spool

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group