Skip site navigation (1) Skip section navigation (2)

Re: Debugger hung on dummy function

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Heikki Linnakangas <heikki(dot)linnakangas(at)enterprisedb(dot)com>
Cc: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: Debugger hung on dummy function
Date: 2009-04-06 20:35:32
Message-ID: (view raw or whole thread)
Lists: pgadmin-hackers
On Mon, Apr 6, 2009 at 9:20 PM, Heikki Linnakangas
<heikki(dot)linnakangas(at)enterprisedb(dot)com> wrote:

> It's reproducible with any other function too, by stepping to the end of the
> function. Which suggests that the problem occurs when the dialog is
> displayed for the 2nd time.

What, the infinite loop happens the second time, or it ignores the
function entirely as I saw with the empty function? I had no problems
debugging a function with just a raise notice in the body multiple
times in a row.

>> Hmm, that's pretty weird. I can't reproduce it here, however I'm on
>> CentOS 5.2 x86_64 which currently only has wxWidgets 2.8.9.
> Probably some gtk/wxwidgets glitch. The backtrace suggests that theme might
> make a difference too..

Yeah, we've seen some themes cause crashes before :-(

>> The line
>> you've commented out simply sizes the grid so that the 'No arguments
>> required' text fits in the first column. Does the following change
>> work for you?
> Yes! That fixes it.

Great - I'll commit that then.


Dave Page
EnterpriseDB UK:

In response to


pgadmin-hackers by date

Next:From: svnDate: 2009-04-06 20:40:05
Subject: SVN Commit by dpage: r7799 - trunk/pgadmin3/pgadmin/debugger
Previous:From: Heikki LinnakangasDate: 2009-04-06 20:21:20
Subject: Re: Debugger hung on dummy function

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group