Skip site navigation (1) Skip section navigation (2)

Re: Support for sslverify

From: Dave Page <dpage(at)pgadmin(dot)org>
To: Magnus Hagander <magnus(at)hagander(dot)net>
Cc: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: Support for sslverify
Date: 2009-03-15 16:00:24
Message-ID: (view raw or whole thread)
Lists: pgadmin-hackers
On Sun, Mar 15, 2009 at 2:51 PM, Magnus Hagander <magnus(at)hagander(dot)net> wrote:
> We've seen it here and Dave reported to me on IM that he has received
> further reports of people getting stuck by the new 8.4 SSL code that
> verifies server certificates by default.
> I think this will happen for example for everybody who has their pg on a
> debian server and their client elsewhere, for example, since debian
> enables a snakeoil SSL cert by default (which in itself is a pretty bad
> idea, but it's what they do)
> Should we provide an option to override this (connection option
> sslverify) in the connection dialog? And is it something we need to do
> for this version (yes, I know it's already in beta..)

There's support for this in libpq aready? If so, then please go ahead
and fix pgAdmin :-)

Note that the server connection diagloue is already pretty much at the
maximum height, so any changes there will probably need to include
splitting of the tabset.

Dave Page
EnterpriseDB UK:

In response to


pgadmin-hackers by date

Next:From: svnDate: 2009-03-15 22:50:21
Subject: SVN Commit by guillaume: r7705 - trunk/pgadmin3/docs/en_US
Previous:From: Guillaume LelargeDate: 2009-03-15 14:55:38
Subject: Re: pgAdminIII 1.10 Visual Tour

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group