Skip site navigation (1) Skip section navigation (2)

[novice] pg_regress.sh problem

From: "Sykora, Dale" <Dale(dot)Sykora(at)COMPAQ(dot)com>
To: "'pgsql-novice(at)postgresql(dot)org'" <pgsql-novice(at)postgresql(dot)org>
Subject: [novice] pg_regress.sh problem
Date: 2001-09-14 00:33:27
Message-ID: 898CFC137378DD44826AC0AAAA5F7BD918E1D8@cceexc22.americas.cpqcorp.net (view raw or flat)
Thread:
Lists: pgsql-novice
Hello,
	I ran into a regression script problem with postgresql7.1.3. I
installed the postgresql-*7.1.3-1PGDG.i386.rpm packages on an x86 box with
RH7.1.  I started the postmaster, su postgres and tried the following per
readme instructions.

bash-2.04$ time ./pg_regress.sh --schedule=parallel_schedule
(using postmaster on Unix socket, default port)
============== dropping database "regression"         ==============
./pg_regress.sh: @bindir@/dropdb: No such file or directory
============== creating database "regression"         ==============
./pg_regress.sh: @bindir@/createdb: No such file or directory
pg_regress.sh: createdb failed

Below is the script section where bindir is initialized

# ----------
# Initialize default settings
# ----------

: ${inputdir=.}
: ${outputdir=.}

libdir='/usr/lib/pgsql'
bindir='@bindir@'
datadir='@datadir@'
host_platform='@host_tuple@'
enable_shared='@enable_shared@'
GCC=(at)GCC@

After determining where dropdb lives, I replaced @bindir@ with /usr/bin and
the test ran.  Is this a script bug or did I miss a step in the install?  8
of 76 tests failed which I need to look into, but I wonder if I need to
replace the other @foo@ values.

Thanks,

Dale Sykora

pgsql-novice by date

Next:From: Jason TanDate: 2001-09-14 02:39:04
Subject: Re: Insert using a subselect?
Previous:From: Andre SchnabelDate: 2001-09-13 18:25:24
Subject: Re: Insert using a subselect?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group