Skip site navigation (1) Skip section navigation (2)

Re: Time to finalize patches for 8.4 beta

From: Grzegorz Jaskiewicz <gj(at)pointblue(dot)com(dot)pl>
To: Bruce Momjian <bruce(at)momjian(dot)us>
Cc: KaiGai Kohei <kaigai(at)kaigai(dot)gr(dot)jp>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Time to finalize patches for 8.4 beta
Date: 2009-01-24 15:43:10
Message-ID: 88A5F6FE-A70C-4EF3-89F9-C93F52A9ACA9@pointblue.com.pl (view raw or flat)
Thread:
Lists: pgsql-hackers
On 2009-01-24, at 15:33, Bruce Momjian wrote:
>
> The PostgreSQL community is considering including security  
> enhancements
> in Postgres 8.4, e.g. row-level permissions and SE-Linux security.
> However, to evaluate the patch and its usefulness, we need security
> experts who want to use this capability or have used it in other
> databases.

With that sort of features, usually what happens in other projects, is  
that despite their evaluation during beta period - they are explicitly  
marked and considered as 'beta', even when product reaches release  
status.
Maybe PostgresSql should follow that tactic too. After all, security  
stuff needs to be tested and exposed for sometime before considered  
rock solid, and trustworthy.
Which of course doesn't mean, that it shouldn't start in beta's.


In response to

Responses

pgsql-hackers by date

Next:From: KaiGai KoheiDate: 2009-01-24 16:24:36
Subject: Re: Time to finalize patches for 8.4 beta
Previous:From: Bruce MomjianDate: 2009-01-24 15:33:20
Subject: Re: Time to finalize patches for 8.4 beta

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group