Skip site navigation (1) Skip section navigation (2)

Re: [PATCHES] Implemented current_query

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Bruce Momjian <bruce(at)momjian(dot)us>
Cc: Alvaro Herrera <alvherre(at)commandprompt(dot)com>, Tomas Doran <bobtfish(at)bobtfish(dot)net>, Neil Conway <neilc(at)samurai(dot)com>, PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: [PATCHES] Implemented current_query
Date: 2008-03-29 16:19:53
Message-ID: 8823.1206807593@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
Bruce Momjian <bruce(at)momjian(dot)us> writes:
> Uh, I think based on other usage it should be called client_statement().

That is *exactly* the wrong thing, because "statement" specifically
means one SQL statement.

"client_query" seems about the best compromise I've heard so far.

It's too bad we didn't have this debate before pg_stat_activity got out
into the wild, because it's now too late to rename its column
current_query.  Possibly we should stick with current_query() just
for consistency with that view ...

			regards, tom lane

In response to

pgsql-hackers by date

Next:From: Dean RasheedDate: 2008-03-29 17:14:36
Subject: Re: [PATCHES] Auto-explain patch
Previous:From: Andrew DunstanDate: 2008-03-29 13:18:22
Subject: Re: [DOCS] pg_total_relation_size() and CHECKPOINT

pgsql-patches by date

Next:From: Tom LaneDate: 2008-03-29 16:35:36
Subject: Re: create language ... if not exists
Previous:From: Andrew DunstanDate: 2008-03-29 13:18:22
Subject: Re: [DOCS] pg_total_relation_size() and CHECKPOINT

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group