"Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us> writes:
> Alvaro Herrera <alvherre(at)commandprompt(dot)com> writes:
>> Tom Lane wrote:
>>> Or we could get radical and rename both of them...
>> Well, it is a bit misleading to have the query_string stuff be named
>> "stats" when it's not actually collected by pgstats at all. Maybe
>> rename it to "collect_query_string". With the other name being
>> "collect_stats", they would show up together in SHOW ALL.
> query_string is pretty misleading these days too, since pg_stat_activity
> includes a lot more than the bare query string.
FWIW I find having both the stats collector and the stats that analyze
generates (ie, stats target) confusing.
Really "stats" doesn't describe what information it's gathering, just that
it's gathering some kind of information. Perhaps we should think of a term
that describes what kind of information that is. collect_io_stats or
"collect_event_stats" or something like that? Or even something without the
word "stats" at all. But I can't think of anything good without it.
> If we were doing this on a blank slate I would suggest "track_stats"
> and "track_activities", but that might be too different from what
> people are used to.
I like "track_events" or "track_activity" though perhaps people might get them
confused with "trace"...
Sigh... and I swore I wouldn't get involved in any more name games...
In response to
pgsql-hackers by date
|Next:||From: Rafael Azevedo||Date: 2007-07-31 19:33:28|
|Subject: feature suggestion|
|Previous:||From: Peter Eisentraut||Date: 2007-07-31 19:06:35|
|Subject: Re: stats_block_level|