Skip site navigation (1) Skip section navigation (2)

RE: Errors building Postgres on NT

From: lbottorff(at)harveycounty(dot)com
To: Bob Love <blove(at)allaire(dot)com>, Jason(dot)Tishler(at)dothill(dot)com, kevlo(at)FreeBSD(dot)org, pgsql-ports(at)postgresql(dot)org
Subject: RE: Errors building Postgres on NT
Date: 2000-11-06 21:40:46
Message-ID: 8625698F.0077173B.00@mail.harveycounty.com (view raw or flat)
Thread:
Lists: pgsql-ports
Unfortunately, it's still not working with exactly the same errors on configure
and make. I followed all instructions to the letter. Again it's this business of
linking to a file that isn't there.... Any ideas?


This is the same problem I posted to this list.  I received the attached
e-mail from Jason Tishler and it works great!

> -----Original Message-----
> From: lbottorff(at)harveycounty(dot)com [mailto:lbottorff(at)harveycounty(dot)com]
> Sent: Friday, November 03, 2000 2:26 PM
> To: cygwin(at)sourceware(dot)cygnus(dot)com; pgsql-ports(at)postgresql(dot)org
> Subject: [PORTS] Errors building Postgres on NT
>
>
>
>
> This is what I get when I try the configure of  postgres
> 7.0.2 on my NT 4.0
> Workstation running cygwin dll 1.1.14
>
> linking ./include/port/win.h to include/os.h
> linking ./makefiles/Makefile.win to Makefile.port
> linking ./backend/port/tas/dummy.s to backend/port/tas.s
> configure: error: ./backend/port/tas/dummy.s: File not found
>
> This is a section of the make where it bombs:
>
> gcc -I../include -I../backend   -I/usr/local/include -O2
> -I/usr/local/include
> -Wall -Wmissing-prototypes -Wmissing-declarations   -c -o
> dllinit.o dllinit.c
> dllinit.c:49: conflicting types for `DllMain'
> dllinit.c:44: previous declaration of `DllMain'
> dllinit.c:49: conflicting types for `_cygwin_dll_entry'
> dllinit.c:49: previous declaration of `_cygwin_dll_entry'
> dllinit.c:81: conflicting types for `DllMain'
> dllinit.c:49: previous declaration of `DllMain'
> make[2]: *** [dllinit.o] Error 1
> make[2]: Leaving directory `/cygdrive/e/postgresql-7.0.2/src/utils'
> make[1]: *** [../utils/dllinit.o] Error 2
> make[1]: Leaving directory `/cygdrive/e/postgresql-7.0.2/src/backend'
> make: *** [all] Error 2
>
> Any ideas? (Besides get Linux--they won't let me!) Has
> anybody seen this before?
>
> Larry Bottorff
>
>


Bob,

On Thu, Nov 02, 2000 at 04:15:12PM -0500, Bob Love wrote:
> Any help would be appreciated.

Please see the following:

    http://people.freebsd.org/~kevlo/postgres/portNT.html

but use the attached patch instead.

Jason



Attachment: Cygwin-1.1.4-PostgreSQL-7.0.2.patch
Description: application/octet-stream (6.0 KB)

pgsql-ports by date

Next:From: Chandra Sekhar . KDate: 2000-11-07 00:17:10
Subject: RE: Has anybody compiled .c file generated from .pgc file
Previous:From: Jason TishlerDate: 2000-11-06 21:37:07
Subject: Re: Re: ps and psql from PostgreSQL not working with cygwin-1.1.5-2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group