Skip site navigation (1) Skip section navigation (2)

RE: Re: A proposal to change psqlodbc

From: Dave Page <dpage(at)vale-housing(dot)co(dot)uk>
To: "'Hiroshi Inoue'" <Inoue(at)tpf(dot)co(dot)jp>
Cc: andrea(dot)aime(at)comune(dot)modena(dot)it, Postgres ODBC <pgsql-odbc(at)postgresql(dot)org>
Subject: RE: Re: A proposal to change psqlodbc
Date: 2001-04-24 09:50:06
Message-ID: 8568FC767B4AD311AC33006097BCD3D61A2ACB@woody.vale-housing.co.uk (view raw or flat)
Thread:
Lists: pgsql-odbc

> -----Original Message-----
> From: Hiroshi Inoue [mailto:Inoue(at)tpf(dot)co(dot)jp]
> Sent: 24 April 2001 10:33
> To: Dave Page
> Cc: andrea(dot)aime(at)comune(dot)modena(dot)it; Postgres ODBC
> Subject: Re: [ODBC] Re: A proposal to change psqlodbc
> 
> 
> Dave Page wrote:
> > 
> > > -----Original Message-----
> > > From: Hiroshi Inoue [mailto:Inoue(at)tpf(dot)co(dot)jp]
> > > Sent: 24 April 2001 09:59
> > > To: andrea(dot)aime(at)comune(dot)modena(dot)it
> > > Cc: Postgres ODBC
> > > Subject: Re: [ODBC] Re: A proposal to change psqlodbc
> > >
> > >
> > > Andrea Aime wrote:
> > > >
> > > > Hiroshi Inoue wrote:
> > > > >
> > > > > Tom Lane wrote:
> > > > > >
> > > > > > Hiroshi Inoue <Inoue(at)tpf(dot)co(dot)jp> writes:
> > > > > > > If there's no objection, I would change the current
> > > > > > > source in a week or so.
> > > > > >
> > > > > > This seems like something to do during 7.2 development,
> > > not as part
> > > > > > of post-7.1 bug fixing.
> > > > > >
> > > > >
> > > > > I can wait to commit it if the 7.2 branch is near
> > > > > but have a basic question.
> > > > >
> > > > > What does 7.2 development mean for clients(psqlodbc) ?
> > > > > Certainly 7.2 would require some changes on clients
> > > > > and I would request some features for psqlodbc.
> > > > > But most changes in client libraries are/have been
> > > > > independent from servers' changes. Strong binding to
> > > > > servers' implementation is one of the most abominable
> > > > > thing for clients. Psqlodbc driver has kept backward
> > > > > compatibility and we have always been able to replace
> > > > > the old driver by the latest one. As long as psqlodbc
> > > > > doesn't intend a big change(e.g. ODBC level 3 support)
> > > > > of its own, it doesn't seems to need the branch.
> > > >
> > > > I see you speak about ODBC level 3 support... does everybody
> > > > know that a project named psqlodbc++ has started at
> > > > http://www.greatbridge.org/project/psqlodbcplus
> > >
> > > Isn't the project released under GPL not LGPL ?
> > >
> > 
> > Which one? The official PostgreSQL driver is LGPL - I don't 
> know about the
> > other.
> > 
> 
> I see the following at
> http://www.greatbridge.org/project/psqlodbcplus/projdisplay.php.
> 
> This project is released under the GNU General Public License (GPL). 

Is this change of licence allowed?

Regards, Dave.

pgsql-odbc by date

Next:From: Cedar CoxDate: 2001-04-24 10:46:30
Subject: Re: ODBC making trobles
Previous:From: Cedar CoxDate: 2001-04-24 09:46:50
Subject: Re: DB grid

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group