Skip site navigation (1) Skip section navigation (2)

Re: Re: [HACKERS] [GENERAL] plperl and regexps with accented characters - incompatible?

From: "Greg Sabino Mullane" <greg(at)turnstep(dot)com>
To: tgl(at)sss(dot)pgh(dot)pa(dot)us
Cc: pgsql-hackers(at)postgresql(dot)org, pgsql-patches(at)postgresql(dot)org
Subject: Re: Re: [HACKERS] [GENERAL] plperl and regexps with accented characters - incompatible?
Date: 2007-12-01 18:25:10
Message-ID: 7b2485d524ff843ebedaf9efb51398ea@biglumber.com (view raw or flat)
Thread:
Lists: pgsql-generalpgsql-hackerspgsql-patches
-----BEGIN PGP SIGNED MESSAGE-----
Hash: RIPEMD160


Tom Lane reports:

>> The version I tested against is 5.8.8 -  the latest stable release. The 
>> 5.8 series started in 2003 from what I can see - if anyone has a 
>> sufficiently old system that they can test on 5.6.2 that will be useful. 

> I got around to trying it with a dusty 5.6.1 I have laying about on my
> HPPA machine, and the news is not good: CREATE LANGUAGE plperl dumps
> core deep inside libperl.  With or without this patch.

Sounds like another good reason to start enforcing a minimum modern Perl 
version. In the past, I advocated making it a minimum of 5.6, but now I 
think a minimum of 5.8 is in order. The first version of 5.8 was released 
in July of 2002, so I don't think we'd be upsetting very many people if 
we did so. Plus, they'd be potentially dumping core anyway, and our energy 
is better spent improving Pl/Perl itself at this point rather than tweaking 
things for old versions of Perl. I don't even think I have a pre 5.8 
version around anymore. Would such a requirement cause any problems with 
packagers? I imagine a perl 5.8 prereq is a common thing these days...


- --
Greg Sabino Mullane greg(at)turnstep(dot)com
PGP Key: 0x14964AC8 200712011322
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8
-----BEGIN PGP SIGNATURE-----

iD8DBQFHUaaevJuQZxSWSsgRA44LAJ9N47I0bIjjILxkOAAUv1ud0lDPAACdEX1J
b3oIV+o0OPrT+RNW03WsGxg=
=0I4i
-----END PGP SIGNATURE-----



In response to

pgsql-hackers by date

Next:From: Josh BerkusDate: 2007-12-01 18:27:48
Subject: Re: Time to update list of contributors
Previous:From: Tom LaneDate: 2007-12-01 17:36:31
Subject: Re: Re: [HACKERS] [GENERAL] plperl and regexps with accented characters - incompatible?

pgsql-patches by date

Next:From: Tom LaneDate: 2007-12-01 19:27:26
Subject: Re: Re: [HACKERS] [GENERAL] plperl and regexps with accented characters - incompatible?
Previous:From: Tom LaneDate: 2007-12-01 17:36:31
Subject: Re: Re: [HACKERS] [GENERAL] plperl and regexps with accented characters - incompatible?

pgsql-general by date

Next:From: Guido NeitzerDate: 2007-12-01 18:50:47
Subject: Re: Postgres High Availablity Solution needed for hot-standby and load balancing
Previous:From: Owen HartnettDate: 2007-12-01 18:08:30
Subject: Re: Linux v.s. Mac OS-X Performance

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group