Skip site navigation (1) Skip section navigation (2)

problem with postgres jdbc driver and Java 1.4.2 sdk

From: Olivier Crameri <olivier(dot)crameri(at)netoxygen(dot)ch>
To: pgsql-jdbc(at)postgresql(dot)org
Subject: problem with postgres jdbc driver and Java 1.4.2 sdk
Date: 2004-03-04 23:48:52
Message-ID: 7DD030EC-6E36-11D8-9523-000393DBA97C@netoxygen.ch (view raw or flat)
Thread:
Lists: pgsql-jdbc
Hi everybody,

Since I've upgraded to Java 1.4.2 on my Mac OSX box, I am having 
extremely strange  problem with jdbc drivers.

I am simply trying to update a resultset via update* methods, and I get 
the following exception :

This method is not yet implemented.
	at org.postgresql.Driver.notImplemented(Unknown Source)
	at org.postgresql.jdbc2.UpdateableResultSet.updateInt(Unknown Source)
	at org.postgresql.jdbc2.ResultSet.updateInt(Unknown Source)
	at testPg.<init>(testPg.java:41)
	at testPg.main(testPg.java:51)

Here is a sample code that is getting me into troubles:

	try {
		stmt = conn.createStatement(
				ResultSet.TYPE_SCROLL_SENSITIVE,
				ResultSet.CONCUR_UPDATABLE);
		rs = stmt.executeQuery("select * from contacts where id = 1");
		
		rs.updateInt("languageId",2);
		rs.updateRow();
		
		}
		catch (SQLException e) {
			e.printStackTrace();
		}
		
Is there any know issue with jdk 1.4.2 on Mac OSX ?

Thank you very much for your help,

Olivier Crameri

Responses

pgsql-jdbc by date

Next:From: 張 欣Date: 2004-03-05 13:05:49
Subject: About use SSL by JDBC
Previous:From: Felix BollenbeckDate: 2004-03-04 18:51:33
Subject: unsubscribe

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group