Skip site navigation (1) Skip section navigation (2)

close-but-not-quite w/ on osx 10.3.8

From: OpenMacNews <OpenMacNews(at)speakeasy(dot)net>
To: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Cc: "Florian G(dot) Pflug" <fgp(at)phlo(dot)org>
Subject: close-but-not-quite w/ on osx 10.3.8
Date: 2005-04-10 19:14:30
Message-ID: 7632493114673E0A9D6A87B6@tiedgar (view raw or whole thread)
Lists: pgadmin-hackers
hi all,

fwiw, i understand that this may be 'old news' for many of you, but -- as I'd 
had some issues getting up-n-running, I just thought i'd share details of what 
I've done so far ... and where I'm currently stalled.

in short, I'm on my way to building pgadmin3 cvs head on OSX 10.3.8 as a 
clickable .app.

my dev env is a bit mod'd, and i'm linking against some of my own builds, so 
here's some of the relevant env/version info:

	Darwin tiedgar 7.8.0 Darwin Kernel Version 7.8.0: Wed Dec 22 14:26:17 PST 
2004; root:xnu/xnu-517.11.1.obj~1/RELEASE_PPC  Power Macintosh powerpc
	gcc v3.3 20030304 (Apple Computer, Inc. build 1671)
	autoconf v2.59
	automake v1.9.5
	libtoolize v1.5.14
	pgsql v8.0.1
	bdb v4.3.27 w/ strong crypto
	perl v5.8.6
	wxWidgets cvsHEAD (config'd "--with-mac")
	python v2.4.1 (framework)
	OpenSSL 0.9.7f 22 Mar 2005
	libxml2 v2.6.18
	expat cvsHEAD
	libpng v1.2.8
	jpeg v6b
	tiff cvsHEAD
	gettext v0.14.3

my procedure is fairly standard, with the exception of the ENV:

% cvs -d :pserver:anonymous(at)cvs(dot)pgadmin(dot)org:/projects co -d pgadmin3-cvs 
% cd /usr/ports/pgadmin3-cvs

# Florian Pflug's patch/files for '.app' creation ...
% wget
% wget

% patch -p0 < pgadmin3-bundle.diff
% gnutar zxvf pgadmin3-newfiles.tgz

% sh bootstrap

% setenv CPPFLAGS "-I/usr/local/ssl/include -I/usr/local/include"
% setenv LDFLAGS "-bind_at_load -L/usr/local/ssl/lib -lssl -lcrypto 
-L/usr/local/lib -lexpat -lintl -lgettextlib -lpng -ljpeg -ltiff -lz"

% ./configure \
--prefix=/usr/local/pgadmin3 \
--enable-appbundle \
--enable-static \
--enable-debug \
--with-wx=/usr/local/wxWidgets-cvs \
--with-wx-config=wx-config \
--with-pgsql=/usr/local/pgsql \

% make all

		Making all in pkg
		Making all in mac
		make[3]: Nothing to be done for `all'.
		make[3]: Nothing to be done for `all-am'.
		make[2]: Nothing to be done for `all-am'.

% sudo make install

% cd /usr/ports/pgadmin3-cvs
% ls -ald
	drwxr-xr-x  4 root wheel 136 Apr 10 11:56

% cd /usr/ports/pgadmin3-cvs/
% otool -L pgadmin3

			@executable_path/../Frameworks/libssl.0.9.7.dylib (compatibility version 
0.9.0, current version 0.9.7)
			@executable_path/../Frameworks/libcrypto.0.9.7.dylib (compatibility version 
0.9.0, current version 0.9.7)
			@executable_path/../Frameworks/libexpat.0.dylib (compatibility version 
6.0.0, current version 6.0.0)
			@executable_path/../Frameworks/libintl.3.dylib (compatibility version 8.0.0, 
current version 8.2.0)
			@executable_path/../Frameworks/libgettextlib-0.14.3.dylib (compatibility 
version 0.0.0, current version 0.0.0)
			@executable_path/../Frameworks/libpng.3.dylib (compatibility version 3.0.0, 
current version 3.0.0)
			@executable_path/../Frameworks/libjpeg.62.dylib (compatibility version 
63.0.0, current version 63.0.0)
			@executable_path/../Frameworks/libtiff.3.dylib (compatibility version 
11.0.0, current version 11.2.0)
			/usr/lib/libz.1.2.2.dylib (compatibility version 1.2.0, current version 
			/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 
(compatibility version 1.0.0, current version 11.0.0)
			/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility 
version 1.0.0, current version 184.0.0)
			/System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility 
version 2.0.0, current version 128.0.0)
			/System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility 
version 1.0.0, current version 9.0.0)
			/System/Library/Frameworks/WebKit.framework/Versions/A/WebKit (compatibility 
version 1.0.0, current version 1.0.0)
			/usr/lib/libiconv.2.dylib (compatibility version 5.0.0, current version 

so, it all looks ok (?) so far ...

but, when I try to dubl-clik the PgAdminIII, i get a dialog:

  'You cannot open the application"PgAdminII" because it may be damaged or 

with no output to the Console/System Log .... hmmmm. ?

also, i'm a little unclear why the install does not install the 
'' where --prefix tells it to, but, rather, in the src tree ... 
but i'd guess that's an arguable point.

gonna google & code-dig a bit; any suggestions in the meantime will be 



pgadmin-hackers by date

Next:From: Florian G. PflugDate: 2005-04-11 09:29:09
Subject: Re: close-but-not-quite w/ on osx 10.3.8
Previous:From: OpenMacNewsDate: 2005-04-10 18:53:57
Subject: Re: [RESOLVED] Re: getting past wxMac-cvs build?

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group