Skip site navigation (1) Skip section navigation (2)

problems installing pgsql

From: Ricardo Gamero <ricardo(dot)gamero(at)gmail(dot)com>
To: pgsql-hackers(at)postgresql(dot)org
Subject: problems installing pgsql
Date: 2005-08-30 18:06:12
Message-ID: 718c06860508301106a730bad@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-hackers
Hello everybody!
 I'm so sorry to post this simple question but I don't know what to do, the 
thing is I need to install postgresql 8.0.3 in red hat 9 but when I try to 
do it this errors appear:
 [root(at)bib root]# rpm -ivh postgresql-server-8.0.3-1PGDG.i686.rpm
warning: postgresql-server-8.0.3-1PGDG.i686.rpm: V3 DSA signature: NOKEY, 
key ID 748f7d0e
error: Failed dependencies:
libcrypto.so.4 is needed by postgresql-server-8.0.3-1PGDG
libpq.so.4 is needed by postgresql-server-8.0.3-1PGDG
libssl.so.4 is needed by postgresql-server-8.0.3-1PGDG
postgresql = 8.0.3 is needed by postgresql-server-8.0.3-1PGDG
postgresql < 7.4 conflicts with postgresql-server-8.0.3-1PGDG
 I've tried installing this packages:

postgresql72-libs-1-3.i386.rpm
postgresql-libs-7.1.3-5.72.i386.rpm 

but I recieve similar errors, I mean dependency. for example:
 [root(at)bib root]# rpm -ivh postgresql-libs-7.1.3-5.72.i386.rpm 
Preparing... ########################################### [100%]
package postgresql-libs-7.2.3-5.80 (which is newer than 
postgresql-libs-7.1.3-5.72) is already installed
file /usr/lib/libecpg.so.3 from install of
postgresql-libs-7.1.3-5.72conflicts with file from package
postgresql-libs-7.2.3-5.80
file /usr/lib/libpgeasy.so.2 from install of
postgresql-libs-7.1.3-5.72conflicts with file from package
postgresql-libs-7.2.3-5.80
file /usr/lib/libpq.so.2 from install of
postgresql-libs-7.1.3-5.72conflicts with file from package
postgresql-libs-7.2.3-5.80
file /usr/lib/libpq.so.2.0 from install of
postgresql-libs-7.1.3-5.72conflicts with file from package
postgresql-libs-7.2.3-5.80
  and I also have tried to download the openssl package, 'cause i read 
somewhere that's what i need, but i can't find the rpm package.
  I'd really apreciate your help and thank you so much for your help!!

Responses

pgsql-hackers by date

Next:From: Tom LaneDate: 2005-08-30 18:07:09
Subject: Re: [Slony1-general] Re: dangling lock information?
Previous:From: Chris BrowneDate: 2005-08-30 16:45:18
Subject: Re: [Slony1-general] Re: dangling lock information?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group