Skip site navigation (1) Skip section navigation (2)

Re: possible problem with version string in win32 port

From: "Merlin Moncure" <merlin(dot)moncure(at)rcsonline(dot)com>
To: "Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: "PostgreSQL Win32 port list" <pgsql-hackers-win32(at)postgresql(dot)org>
Subject: Re: possible problem with version string in win32 port
Date: 2004-11-04 13:54:38
Message-ID: 6EE64EF3AB31D5448D0007DD34EEB3412A7516@Herge.rcsinc.local (view raw or flat)
Thread:
Lists: pgsql-hackers-win32
> "Merlin Moncure" <merlin(dot)moncure(at)rcsonline(dot)com> writes:
> > ...  It turns out pg_ctl is trying to compare
> 
> > postmaster (PostgreSQL) 8.0.0\n   <-- on the pg_ctl side
> > with
> > postmaster (PostgreSQL) 8.0.\n    <-- on the postmaster side, read
from
> > popen with -V switch.
> 
> I couldn't reproduce this on Linux.  There is Windows-specific code in
> pipe_read_line(), which seems like it might be the root of the
problem,
> but I can't see anything obviously wrong with it.

Me neither.  Maybe I'm just blowing smoke.  I'll double and triple check
this though...if this is a real problem it obviously has to be fixed
before the release.

Merlin

pgsql-hackers-win32 by date

Next:From: Bruce MomjianDate: 2004-11-04 22:24:43
Subject: Re: Edit query buffer
Previous:From: Tom LaneDate: 2004-11-04 03:18:33
Subject: Re: Edit query buffer

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group