Skip site navigation (1) Skip section navigation (2)

Re: [BUGS] PSQL commands not backwards-compatible

From: "Magnus Hagander" <mha(at)sollentuna(dot)net>
To: "Bruce Momjian" <pgman(at)candle(dot)pha(dot)pa(dot)us>,"Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: <josh(at)agliodbs(dot)com>,"PostgreSQL-patches" <pgsql-patches(at)postgresql(dot)org>
Subject: Re: [BUGS] PSQL commands not backwards-compatible
Date: 2005-08-31 08:21:07
Message-ID: 6BCB9D8A16AC4241919521715F4D8BCE6C796A@algol.sollentuna.se (view raw or flat)
Thread:
Lists: pgsql-patches
> > > Here is a patch that will print out (in interactive mode only) a 
> > > warning message if a newer client connects to an older 
> major numbered server.
> > 
> > Why only older?  It's even less likely to work if the 
> server is newer.
> > 
> > (I don't agree with the premise to begin with...)
> 
> OK, this new patch prints a warning on any major version 
> mismatch, newer or older.

I would suggest showing both the client and server versions that
mismatched. If you're in a scenario with several versions on the same
machine of both client and server (hosting scenario, I'd imagine), that
would certainly help. 

//Magnus

Responses

pgsql-patches by date

Next:From: Josh BerkusDate: 2005-08-31 17:00:11
Subject: Re: PSQL commands not backwards-compatible
Previous:From: Michael FuhrDate: 2005-08-31 04:41:11
Subject: SPI_getbinval() documentation correction

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group